Error message - Collabora Online is not setup yet

I downgraded too and now it works again. Thanks for the instructions. I’ll try upgrading later when I have more time for it.

dear forumists,

this thread is a nice example of how important it is to give out informations about your instance.
like we don’t know if the threadstarter is running their instance as a docker… or under UCS or whatever.
and then we do have solutions for docker and UCS. i mean solutions are great. in general. but as long as we don’t know anything about the setting(s) of threadstarter we can’t mark this one being solved.

and - btw - because we don’t know anything about the problematic instance of TS there can’t be any “i have the same problem”… since it might not bei the same.

just saying… and hopefully reminding you to stay to the code of conduct and nc-guidelines - as there are good reasons doing so.

3 Likes

I had to downgrade to version 3.5.0 to get it working again (docker). Any version between 3.5.0 and 3.6.0 was returning error message -

Failed to load Collabora Online - please try again later.

With version 3.6.0, had same issue as OP:

Collabora Online is not setup yet.
Click here to configure your own server or connect to a demo server.

Hi JimmyKater, guess its me that started this tread. Im running an CentOS 7 server in VMware. AND ofcource we all have the same problem since we all got the same error message, an error that came with that new releaase. Dosent matter if you are on docker or on a server, we all use the same software and the problem is within the software. And the tread is not resolved until “nextcloud” releases a working version. BUT thats only my opinion.

Regards

doesnt equal docker in any way. and only because the errormessage seems to be similar it doesn’t need to be the same problem. like: there are many thousands of users not experiencing this behaviour. so … it needs to be something which is apparently connected with your individual setup. a hint could be: your posted “solution” apparently doesn’t help everyone here. but if it was the SAME error it had to be the solution for everyone.

plus: you filed your isse here under support… and the very moment you’re opening a new thread under support you’re asked to fill out a template. which YOU completely removed, sparing any neccessary information about your instance on purpose. let me ask you: why did you do that? because you know it better than devs who implemented this template? or just to make it harder for peeps on the forum to find a valid answer quickly? just tell me…

but hey… if you think it’s a bug in the code go to github and file an offical isse there. be prepared to 1. search for already existing similar issues and 2. after you made sure there is none 3. to give out all information you’re asked for by the template (hint: do install app issue-template to your server, it’ll be of great help).

thanks for your understanding and keeping to the guidelines and code of conduct of nextcloud. at least for your future postings.

cheers
jimmy

1 Like

Thank You … :+1:

Hey,
Dont downgrade the app. You can find the solution here :

You have to change the config of nginx or Apache. You should best to do that because all next upgrades of collqbora will works with the new config.

For those who didn’t get it solved anyway…
I’ve disabled richdocuments app and installed WOPI one. Works fine and collabora is back! :relieved:

1 Like

Hey
There is no problem with richdocument. Collabora online had changed the configuration file of apache. So everything works if you update your config. Look at the link of my last comment, there is the solution :wink:

Thanks Marc, saved my tea break !

Today I bumped versions of nextcloud (from 18.0.0 to 18.0.6) and collabora ( from 4.2.0.3 to 4.2.5.3) and get this error message.

Do I need to do the same “fix” as mentioned?

version: '2'
services:
  web:
image: nginx
container_name: nextcloud_webserver
volumes:
  - /data/disk1/nginx-nextcloud/nginx.conf:/etc/nginx/nginx.conf:ro
links:
  - app
  - collabora
volumes_from:
  - app
environment:
  - VIRTUAL_HOST=subdomain.domain.se
  - VIRTUAL_NETWORK=nginx-proxy
  - VIRTUAL_PORT=80
  - LETSENCRYPT_HOST=office.domain.se
  - LETSENCRYPT_EMAIL=user@domain.se
networks:
  - proxy-tier
restart: always

  app:
image: nextcloud:18.0.6-fpm
container_name: nextcloud_fpm
volumes:
  - /data/disk1/nextcloud/apps:/var/www/html/apps
  - /data/disk1/nextcloud/config:/var/www/html/config
  - /data/disk1/nextcloud/data:/var/www/html/data
environment:
  - POSTGRES_DB=nextcloud
  - POSTGRES_USER=nextcloud
  - POSTGRES_PASSWORD=***************
  - POSTGRES_HOST=192.168.1.20
networks:
  - proxy-tier
restart: always

  collabora:
image: collabora/code:4.2.5.3
container_name: nextcloud_collabora
cap_add:
  - MKNOD
environment:
  - domain=subdomain.domain.se
networks:
  - proxy-tier
restart: always

networks:
  proxy-tier:
external:
  name: nginx-proxy

I got it solved by enabling Nextcloud Collbora integration and then “use demo server” and back to own server…for some reason it started to work again

Hi,

As suggested by @Marc1721, I looked at issue 949 and especially this comment which suggest a better solution than downgrading : update the apache / nginx configuration if collabora is behind a reverse proxy (which is usually the case for the docker version).

  • for apache
# Capabilities
ProxyPass           /hosting/capabilities https://127.0.0.1:9980/hosting/capabilities retry=0
ProxyPassReverse    /hosting/capabilities https://127.0.0.1:9980/hosting/capabilities
  • for nginx
# Capabilities
ProxyPass           /hosting/capabilities https://127.0.0.1:9980/hosting/capabilities retry=0
ProxyPassReverse    /hosting/capabilities https://127.0.0.1:9980/hosting/capabilities

I only tested the appache configuration and it fix the issue.

To be fair, @bastien suggested earlier to update the apache / nginx configuration but did not give the lines and some people still seems to struggle

Hello

Actually, I have given a link link in my second comment. This is a link for another thread of this website where I gave the lines for nginx. There are also lines for Apache.

Id have To be clearer but I didn’t want to insist on this discussion that goes in all directions.d

I first used this solution:

Worked well for some month, until I installed a minor update to Nextcloud - it updated all Apps automatically - and the same problem was back.

I looked for a better solution. Found this:

Well, I really don’t want to change server config files, just because some Nextcloud app decides to work different now.

So I used the third solution:

That solved it for me - hope it survives the next updates.

To do it just search for “WOPI” in the Nextcloud Apps section. Install that app.
Copy the Server-URL and Port from the Collabora app settings and paste it to the WOPI app settings (the app is called “Office Online” in the settings page instead of WOPI, but ok…). Then deactivate that Collabora/richdocuments app (they really have a problem with naming the apps…).

You may need to reload Nextcloud in the browser after the changes, then it should be possible to open office files again.

WHY has this be so complicated? Nextcloud is a wonderful self hosted server solution which is easy to install and operate, but connecting Collabora just for opening office files (the most basic thing someone would expect from an own cloud server) is complicated to setup (own subdomain etc. even if all runs on the same server, extra docker container…) and then randomly stops working because an app gets updated (and never fixed). Onlyoffice is not better, there you can edit but not save back to your nextcloud server…

… I dont have words anymore

You say

So, if edits are too complicated, maybe you don’t realize what means developments,upgrading…
When nextcloud himself decide to change the config of Apache or nginx (to improve performance or security for example), you can’t say that. It’s just normal. But its true that there is a problem of communication from collabora.

And collabora is not complicated to set up. With docker installation, it’s just 3 commands lines

I am sorry for that

“never change a running system”

it is quite complicated (compared to other Nextcloud apps), cause you need to set up the reverse proxy thing with an own subdomain just for collabora, plus an own ssl cert.

Nextcloud did an amazing job in how they made their software easy to set up and especially easy to upgrade. Very stable, upgrades in the browser just work, zero problems so far. But office suites are still painful to integrate. I tried Onlyoffice - did not save files back to my server, so unusable. Collabora: Works mostly, but from time to time those weird problems (“you upgraded my app, so I don’t find my server any more” - even if all runs just on the same machine). Hopefully one day the office suite will come just integrated like a calendar or notes app - so that more any more people can leave their public clouds and can come to a self hosted Nextcloud.

I adminstrate a NC and I dont have a subdomain for collabora and ssl cert… In the documentation, its clearly said that you should create your own subdomain but its not necessary…
Moreover, you dont need another certificate even with your own subdomain. You can create only one ssl cert which protect domain and all subdomains with wildcard rules.
“Set up reverse proxy” -> you can use nginx, proxy is native.

There is a bug with onlyoffice. OO document server is very recent, be patient. I agree that one more time there is a problem of communication from NC. You can install OO community server, its more complicated but it works.

Actually, its normal that you need to install server and application for OO or Collabora. OO and Collabora are projects in its own right and are not developped by NC.
Moreover, its better to separate server from interface if you want to set up a big installation (you install NC on a machine and collabora/OO server on another machine just like BBB, Element…)
So, an application “2 in 1” was secondary for NC. And, it is just started with OO in NC18 and collabora with NC19.

This topic was automatically closed 125 days after the last reply. New replies are no longer allowed.