Error message - Collabora Online is not setup yet

Latest update got me into tubble.
" [Collabora Online is not setup yet.
Click here to configure your own server or connect to a demo server."

I click the link and klick save but i get the same error message again and again…

May 12 08:00:50 Updated: collaboraoffice6.2-ure-
May 12 08:00:54 Updated: collaboraofficebasis6.2-core-
May 12 08:00:54 Updated: collaboraofficebasis6.2-images-
May 12 08:00:55 Updated: collaboraoffice6.2-
May 12 08:00:57 Updated: collaboraofficebasis6.2-ooofonts-
May 12 08:00:57 Updated: collaboraofficebasis6.2-extension-pdf-import-
May 12 08:00:57 Updated: collaboraofficebasis6.2-graphicfilter-
May 12 08:00:57 Updated: collaboraofficebasis6.2-writer-
May 12 08:00:58 Updated: collaboraofficebasis6.2-ooolinguistic-
May 12 08:00:58 Updated: collaboraofficebasis6.2-calc-
May 12 08:00:58 Updated: collaboraofficebasis6.2-draw-
May 12 08:00:58 Updated: collaboraofficebasis6.2-impress-
May 12 08:00:58 Updated: collaboraofficebasis6.2-en-US-
May 12 08:01:02 Updated: loolwsd-4.2.3-1.el7.x86_64
May 12 08:01:03 Updated: CODE-brand-4.2-21.noarch
May 12 08:01:03 Updated: collaboraoffice6.2-dict-en-
May 12 08:01:03 Updated: collaboraoffice6.2-dict-sv-
May 12 08:01:03 Updated: collaboraofficebasis6.2-sv-
May 12 08:01:05 Updated: loolwsd-debuginfo-4.2.3-1.el7.x86_64

Love this util and im very depended upon it so please advise.


I have the same problem in my docker install. When I connect collabora its ok but if I refresh the page, it appears that collabra wasn’t connected

Install wopi and configure like Collabora online and its working again!
Think wopi is devel edition or someting like it…

can you explain please? Do you have docker installation ?

Hi. Same problem for me since i updated collabora online. Collabora is on docker installation. I activated wopi and the file opened in a new window with editing available. But i can’t save the file…

since this morning I’ve got the same problem with “Collabora Online is not setup yet”. I’m running Nextcloudpi in a Docker container with the latest Collabora Online Docker Image. My Nextcloud instance is on version 18.0.4 and I had no issue so far with it. I tried “docker pull collabora/code” to update the docker image but i get the same error.

After some research I’ve found this issue which talks about downgrading the Nextcloud “Collabora Online” App from version 3.6 .0 back to 3.5.3. After I downgraded to 3.5.3 my collabora is working fine again.

How to downgrade:

  1. DisableCollabora Online App in Apps section
  2. Remove Collabora Online App
  3. Connect to your Nextcloud instance via SSH and go into the nextcloud folder/docker volume of your Nextcloud Instance and cd into the apps folder. There you can download the old version" and unpack it in the apps folder.
  4. Go back in the Apps Section of your Nextcloud instance and enable the Collabora Online App again and try editing a document

Thanks a lot. Its working again

Hello in wich folder is this exactly ive ran this command

occ $ app:getpath richdocuments


But if i ssh to my server and try to go into this folder /var/www/html/apps/richdocuments it tell me it don’t exist

root@cloud:/# cd /var/www/html/apps/richdocuments
-bash: cd: /var/www/html/apps/richdocuments: No such file or directory

Can you please help me

Thanks !


this doesn’t look like the nextcloud directory with the apps folder. The Nextcloud Directory with the apps folder should look something like this:

there you can see the “apps” directory.

Based on your ls command I think that your nextcloud directory is /var/lib/univention-appcenter/apps/nextcloud and the apps folder then should be /var/lib/univention-appcenter/apps/nextcloud/apps but I cant say for sure, because I don’t know your system.

Im using this as a VM

ive found it in here


Ive renamed the richdocuments to richdocumentsOLD and unzip the zip to create the richdocuments

Now in my console i see the Collabora Online 3.5.3 but it keep being disable. I click on Enable and if i do a refresh it keep going back to Disable

Any idea ?

Check if the ownership of the richdocuments folder is the same as the other app folders

drwxr-xr-x 13 root root 4096 May 12 16:37 richdocuments
drwxr-xr-x 13 www-data nogroup 4096 Apr 22 17:19 richdocuments3.6.0

How i can make the same permission ?


chown -R www-data:nogroup richdocuments

Ok ive done it

drwxr-xr-x 13 www-data nogroup 4096 May 12 16:37 richdocuments
drwxr-xr-x 13 www-data nogroup 4096 Apr 22 17:19 richdocuments3.6.0

i can’t enable it it keep coming back to diable app…

Ill reboot the server to check…

Server is reboot and same problem can’t enable the app it keep going back to disable apps :frowning:

Do you see any errors in the settings menu under logging ( ?

Yes there is alot of error going on

Okay there are only some LDAP Backend errors, nothing releated to the Collabora App as far as I can tell.
At this point I would start to guess and troubleshoot myself.
Maybe you need to wait for a Patch from the Collabora guys or use the build in onlyoffice Document server for a while.

ok thanks for your help !

Ok if this can help someone using nextcloud with UCS and docker container here is the step to revert back Collabora Online 3.6.0 to version 3.5.3

1- In nexcloud active apps page disable the apps “Collabora Online” 3.6.0

2- In nexcloud disable apps page remove the apps “Collabora Online” 3.6.0

3- In ssh on the UCS server you need to find docker container id
root@cloud:/# docker ps
2fedffc6d0d7 “/bin/sh -c 'bash st…” 12 hours ago Up 12 hours>9980/tcp wonderful_brattain
d9c5ae57ed42 “/bin/sh -c /usr/sbi…” 21 hours ago Up 12 hours>80/tcp determined_shamir

4- Transfer the richdocuments.tar.gz to the UCS server with WinSCP. The file can be download here

5- Copy the gz file in the docker container - docker cp richdocuments.tar.gz :
root@cloud:~# docker cp richdocuments.tar.gz d9c5ae57ed42:/var/www/html/apps

6- Go inside nextcloud docker container
root@cloud:~# univention-app shell nextcloud

7- Extract the .gz file and give the same permission as other folder
root@nextc-57258297:/var/www/html/apps# tar zxvf richdocuments.tar.gz
root@nextc-57258297:/var/www/html/apps# chown -R www-data:nogroup richdocuments

8- Return in nexcloud apps page and enable the apps “Collabora Online” version 3.5.3

Collobara Online 3.5.3 work again

Ive post it on the UCS Forum too