Error in users interface

#1
Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 15.0.7):
Operating system and version (eg, Ubuntu 18.04.02):
Apache or nginx version (eg, Apache 2.4.29):
PHP version (eg, 7.2.17):
Mysql: 10.1.38

The issue you are facing:

Is this the first time you’ve seen this error? (Y/N): N

Steps to replicate it:

When I’am connect to the interface with admin user, and i want to see the users, i have an error, i can’t see old users but i can create new but not see after creating.
The output of your Nextcloud log in Admin > Logging:

PASTE HERE
`Doctrine\DBAL\Exception\DriverException: An exception occurred while executing 'SELECT `uid`, `displayname` FROM `oc_users` `u` LEFT JOIN `oc_preferences` `p` ON (`userid` = `uid`) AND (`appid` = 'settings') AND (`configkey` = 'email') WHERE (`uid`  COLLATE utf8mb4_general_ci LIKE ?) OR (`displayname`  COLLATE utf8mb4_general_ci LIKE ?) OR (`configvalue`  COLLATE utf8mb4_general_ci LIKE ?) ORDER BY `uid_lower` ASC LIMIT 25 OFFSET 0' with params ["%%", "%%", "%%"]:

SQLSTATE[42000]: Syntax error or access violation: 1253 COLLATION 'utf8mb4_general_ci' is not valid for CHARACTER SET 'utf8' at <<closure>>``

The output of your config.php file in `/path/to/nextcloud` (make sure you remove any identifiable information!):

PASTE HERE


The output of your Apache/nginx/system log in `/var/log/____`:

PASTE HERE

#2

I think you haven’t tried to use the search function of this forum. Otherwise you should have found the following postings which are all covering this kind of error message and are also providing a solution:




https://help.nextcloud.com/search?q=COLLATION%20utf8mb4_general_ci%20is%20not%20valid%20for%20CHARACTER%20SET%20%27utf8

1 Like
#3

I’m sorry but i search in my data base and i found oc_users it’s with the good option. ! See capture:Capture|690x25 .
I think it’s an error in a file and it was occured when i upgraded my server.
In the log i see “utf8mb4_general_ci’ is not valid for CHARACTER SET 'utf8”.

#4

Yes, as referenced, it is a database configuration problem which you need to adjust. The postings contain information how this can be done.