Error in Notes app after moving the data directory

I’m getting an error (“Error from Nextcloud server: Exception”) and no notes will load. Do I need to clear the app cache or something else?

What does your Nextcloud log say? What’s in your browser log (F12)? What Nextcloud and Notes versions are you using? Did you run the occ scan command after messing around on file system level?

Please share some more information about your environment and what you did. “There is an error” is a little hard to solve :wink:

Nextcloud version: Nextcloud Hub II (23.0.3)
Notes version: 4.5.1

I tried running occ files:scan but that namespace no longer exists in the occ command. occ scan doesn’t work either.

Tail end of the log ends with this message: ““CustomMessage”:“Could not generate Content Etag for note 480”}}”

(I haven’t downloaded ‘nextcloud.log’ from the server, but this is the message repeated all throughout a fresh log when clicking on notes).

In this case I recommend you to create a bug report at the Notes apps issue tracker so the actual developers can help you further.

Please keep in mind to fill in the complete issue template and also link to this help forum thread.

After some further digging, I found out that the reason the scan wasn’t working is because maintenance mode was on when I tried to run it. When I do run it, I get an error about the home directories for each user not being writable.

Further digging on the internet leads me to believe the issue is with the database, not the Notes app. However, the solution mentioned here: OwnCloud: Fix ‘home storage for user not writable’ error – - doesn’t work.

Reason being, there seems not to be a “home” in the oc_accounts table. I’m guessing I just need to know now what is the correct command equivalent to: select * from oc_accounts where home not like ‘%/mnt/my_cloud_drive/nextcloud-data/nextcloud-data/%’ and then ```
update oc_accounts set home = ‘/var/www/html/owncloud/data/testuser’ where id = 123;

I moved my notes save location and the notes themselves. Now I get sync issues and have to approve each change. Did you ever sort out this app? I might just reenter each note and delete the old ones and see if that helps.