Error for streaming videos larger than 2GB

The Browser interface won’t play videos larger than 2 GB. As far as I can tell this seems to be a hard limit with everything just below playable. I think this might be something I could change in a config somewhere, does anyone know about this?

Nextcloud version: 17.0.1
Operating system and version: Debian 10
Apache or nginx version: apache 2.4.38
PHP version: 7.3

Is this the first time you’ve seen this error? (Y/N): Yep

Steps to replicate it:

  1. Navigate to Video section in Browser
  2. Click on Video

The output of your Nextcloud log in Admin > Logging:

Error  PHP  fseek() expects parameter 2 to be int, string given at /var/www/html/nextcloud/3rdparty/sabre/dav/lib/DAV/CorePlugin.php#177

there I’d check if you use a 32-bit php version.

as well:

Ah, it seems it is 32 bit. Is there a way to change this?

Well, you’d have to replace a lot of things in your OS. I don’t know if debian has a standard routine for that or if you have to reinstall.