Error connecting in internal network

#1

Hello

If I want connect directly from a Windows client to NC with Desktop app with the internal ip address, I got the message “ERR_CERT_COMMON_NAME_INVALID” . (Letsencrypt"

If I connect with the DNS name, I have no problem.

I want to synchronice directly via the internal network, what should I do?

Thanks

Linux Client Setup wizard Does not ignore SSL on internal Network
#2

Depending on how many clients you have, you can set up your own DNS resolver, or edit the /etc/hosts file (on Linux/macOS) to point to your Nextcloud server.

#3

I have only two clients and with osx it works fine but with Windows not

#4

Search for ‘Windows hosts file’ and make the same changes there. :+1:

#5

I did it, made changes you said

No solution

#6

After adding the entries to your hosts file, you should be able to resolve the DNS names internally, so you can use your DNS name to synchronise locally with Nextcloud.

#7

that is not the problem, I got the error ERR_CERT_COMMON_NAME_INVALID if I want connect with the ip address and the desktop app

#8

I have same problem I think, although client is in linux

When trying to set up the account in the client 1st run wizard (or afterwards using the ‘add account’ option) on my new Manjaro installation I can’t connect to local server on my network if using local address - it gives same error as you get, even though I check the ‘trust this certificate anyway’ box, AND I have added the entry to my hosts file.

However, all works if using external address (but is so bloody slow!)

I have:

Client configuration
Client version: 2.5.1-2
Operating system:
Manjaro

Server configuration
Nextcloud Box
Raspberry Pi
Snappy

However, the client is still working on my other dual boot installed OS - Xubuntu 18.04.1, although I dont have to go through the 1st time wizard as it has been set up for some time.

I think these bugs are relevant but dont have much of an idea


So, not very helpful, but at least you are not alone!

#9

Hi there. For internal network access you have to use http instead of https. Because you use Letsencrypt for cert with a domain name, Nextcloud expects the name (IP or Domain) to match the cert name.

Hope it helps you. Cheers.

#10

Cant use http, automatically changes to https
Its the ‘ignore cert’ box that’s being ignored

Seems to be a bug in client:
See issues Github #705, #849, #997

#11

I got the same problem. The solution for me was to download the latest version of Windows client. The version is 2.5.2. It is now connecting to the local private IP address.

#12

Can confirm 2.5.2 on Manjaro works now