Error Conflict files and error "the server did not acknowledge the last chunk. (No e-tag was present)""

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): 20.0.8
Operating system and version (eg, Ubuntu 20.04): debian9~1.gbpb21322
Apache or nginx version (eg, Apache 2.4.25): Apache 2.4.25
PHP version (eg, 7.4): PHP 7.2.34

Issue :

we have a problem with Conflict files.
And the error : " The server did not acknowledge the last chunk. (No e-tag was present)"

Is this the first time you’ve seen this error? : N

Steps to replicate it:

  1. Save a file (for example just a simple .txt file (1ko)
  2. The sync lauch… and we receive an error " The server did not acknowledge the last chunk. (No e-tag was present)"" in the NC client panel admin
  3. We modify the file (we have frequent updates of the same files) since it’s still in “error” (the update is ok in the webserver)
  4. sync retry… successfully, but it create a conflict files, because NC think that there is a conflict

The output of your Nextcloud log in Admin > Logging:
No rerror in the web debug (level debug is 2)

The output of your Apache/nginx/system : unfortunnaly, no log for this error…

Config.php :

$CONFIG = array (
  'debug' => true,
  'trusted_domains' => 
  array (
    0 => 'XXXX.domain',
  'datadirectory' => '/home/path/to/public_html/dev',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => 'https://domain.url',
  'dbname' => 'db_name',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'user_db,
  'dbpassword' => 'pass,
  'installed' => true,
  'mail_from_address' => 'smtp',
  'mail_smtpmode' => 'smtp',
  'mail_domain' => 'domain,
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtpauth' => 1,
  'mail_smtpport' => '25',
  'mail_smtphost' => 'localhost',
  'mail_smtpname' => 'smtp_name,
  'mail_smtppassword' => 'pass',
  'log_type' => 'file',
  'logfile' => '/path/to/log/nextcloud.log',
  'logfilemode' => 416,
  'loglevel' => '2',
  'logdateformat' => 'F d, Y H:i:s',
  'updatechecker' => false,
  'log_query' => true,
  'memcache.local' => '\\OC\\Memcache\\Redis',
  'redis' => 
  array (
    'host' => 'localhost',
    'port' => 6379,
    'timeout' => 0.0,
  'filelocking.enabled' => true,
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'filelocking.debug' => true,
  'filelocking.ttl' => 1200,
  'filelocking.debug' => true,
  'updater.secret' => 'key,
  'maintenance' => false,
  'app_install_overwrite' => 
  array (
    0 => 'mycustomhooks',
    1 => 'admin_notifications',

We have read (all ?) the post from this error, which seems to exist for years.
We have :

  • deactived Mod_security, Deflate…
  • we don’t use encyption
  • files:scan, files:scan-app-data, files:cleanup… already done

We use Redis for the cache, we have tried to change it too…

Do you have any solution ? it’s a big problem for us…


I have the same issue. Started some time ago.

Same here, started last week.