Error building from source the OSX Desktop Client. Any tips?

Error on final stage of building OSX Client from source

Followed all of the steps in the build for OSX guide:

I get a failed build. Seems like I’m missing some “rules” to make target but I’m not sure what to do from here.

I can obviously go and create an …/install folder but should the script not do this?

It also seems to be complaining about the Sparkle framework and missing rules.

Pretty lost at this last step how to proceed.

Any help would be greatly appreciated.


Terminal Output which shows the errors from running : sh osx/

[ 25%] Building CXX object src/libsync/CMakeFiles/owncloudsync.dir/__/3rdparty/qjson/json.cpp.o
[ 26%] Building CXX object src/libsync/CMakeFiles/owncloudsync.dir/creds/httpcredentials.cpp.o
[ 26%] Building CXX object src/libsync/CMakeFiles/owncloudsync.dir/owncloudsync_automoc.cpp.o
make[2]: *** No rule to make target /Users/builder/Library/Frameworks/Sparkle.framework', needed bysrc/libsync/libowncloudsync.2.3.1.dylib’. Stop.
make[1]: *** [src/libsync/CMakeFiles/owncloudsync.dir/all] Error 2
make: *** [all] Error 2
[ 3%] Built target cstdlib
[ 9%] Built target ocsync
[ 10%] Automatic moc for target owncloudsync
[ 10%] Built target owncloudsync_automoc
make[2]: *** No rule to make target /Users/builder/Library/Frameworks/Sparkle.framework', needed bysrc/libsync/libowncloudsync.2.3.1.dylib’. Stop.
make[1]: *** [src/libsync/CMakeFiles/owncloudsync.dir/all] Error 2
make: *** [all] Error 2
sudo: /Users/colm/client_theming/client/admin/osx/ command not found
Reference folder ‘…/install/’ does not exist.
Failed to create ownCloud-
osx/ line 36: /Users/colm/install/*.tbz: No such file or directory
mv: rename /Users/colm/sig.txt to /Users/colm/install/signature.txt: No such file or directory

MacBook-Air:client_theming colm$

I think il join this thread here also with the same issue actually. Also struggling with this similar error output. I seem to have gotten a good deal of distance into the build itself but struggling with the documentation at install folder step. I will run my steps again and attach my full output. Any help would be much appreciated. Thanks James

1 Like

To help here is the full output:

I am afraid I know little of what causes the breakage (maybe you need a thing called Sparkle.framework?) but I would want to share that there will soon be official packages for 2.3.1.

1 Like

Thanks @jospoortvliet.

I am going through all the steps again from scratch to ensure I didn’t miss anything here! Will let you know how I go. I included the sparkle framework.

Thanks @jospoortvliet for your help mate. It was sparkle framework not being picked up. Corrected it and progressing the build from source.

I am running into the same issue, I have had to run through the process 3 times already and it is a huge time suck since this line takes like 5 hours to complete ‘make -j2’. I am now getting the same error you mentioned above, how did you resolve this? I have sparkle installed on the system since I did that in the dependencies step. Is there something I am missing?

The solution for me was to chmod the Sparkle.Framework.

Hi Jess, apologies, I missed that first notification from the forums. I stepped back through the Sparkle. Framework steps and it worked for me the second time. I had a path wrong for my setup on my Mac. I hope you have resolved the issue. Happy to look at log files or debug if you have further issues. Cheers