Error 500 after update

Hello,
I have a proplem after update on Nexcloud.
error 500

I’m on
Apache 2.4
PHP8.1

Check your nextcloud.log

Tanks this is an extract of the log

{"reqId":"ZKw5t848HjGIZcQnL0Kp7QAAAAE","level":3,"time":"2023-07-10T17:02:47+00:00","remoteAddr":"37.166.4.1","user":"--","app":"PHP","method":"PROPFIND","url":"/remote.php/dav/addressbooks/users/Sebastien%20Obierti/contacts/","message":"Declaration of OCA\\Talk\\Share\\RoomShareProvider::getSharesInFolder($userId, OCP\\Files\\Folder $node, $reshares): array must be compatible with OCP\\Share\\IShareProvider::getSharesInFolder($userId, OCP\\Files\\Folder $node, $reshares, $shallow = true) at /srv/web/obierti-cloud/apps/spreed/lib/Share/RoomShareProvider.php#520","userAgent":"DAVx5/4.3.4.1-gplay (2023/06/13; dav4jvm; okhttp/4.11.0) Android/13","version":"24.0.12.1","data":{"app":"PHP"}}                 {"reqId":"ZKw9UAwqVaOtIpe8mCqNxwAAAAY","level":3,"time":"2023-07-10T17:18:08+00:00","remoteAddr":"37.166.4.1","user":"--","app":"PHP","method":"PROPFIND","url":"/remote.php/dav/addressbooks/users/Sebastien%20Obierti/contacts/","message":"Declaration of OCA\\Talk\\Share\\RoomShareProvider::getSharesInFolder($userId, OCP\\Files\\Folder $node, $reshares): array must be compatible with OCP\\Share\\IShareProvider::getSharesInFolder($userId, OCP\\Files\\Folder $node, $reshares, $shallow = true) at /srv/web/obierti-cloud/apps/spreed/lib/Share/RoomShareProvider.php#520","userAgent":"DAVx5/4.3.4.1-gplay (2023/06/13; dav4jvm; okhttp/4.11.0) Android/13","version":"24.0.12.1","data":{"app":"PHP"}}                 {"reqId":"ZKw-MbqWoqf3GGrTnBN77gAAAAQ","level":3,"time":"2023-07-10T17:21:54+00:00","remoteAddr":"192.168.1.254","user":"--","app":"PHP","method":"GET","url":"/","message":"Declaration of OCA\\Talk\\Share\\RoomShareProvider::getSharesInFolder($userId, OCP\\Files\\Folder $node, $reshares): array must be compatible with OCP\\Share\\IShareProvider::getSharesInFolder($userId, OCP\\Files\\Folder $node, $reshares, $shallow = true) at /srv/web/obierti-cloud/apps/spreed/lib/Share/RoomShareProvider.php#520","userAgent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:109.0) Gecko/20100101 Firefox/114.0","version":"24.0.12.1","data":{"app":"PHP"}}