Erreur de mise à jour 18 -> 19

Bonjour à tous,

J’ai un problème lors de la mise à jour de la v18 à la v19, tout ce passe bien jusqu’à la mise à jour de l’extension workflowengine., il y a le message d’erreur suivant :

Set log level to debug
Updating database schema
Updated database
Updating <workflowengine> ...
Doctrine\DBAL\Exception\InvalidFieldNameException: An exception occurred while executing 'UPDATE `nc_flow_operations` SET `entity` = ? WHERE `entity` = ''' with params ["OCA\\WorkflowEngine\\Entity\\File"]:

SQLSTATE[42S22]: Column not found: 1054 Unknown column 'entity' in 'where clause'
Update failed
Maintenance mode is kept active
Reset log level

Pour procéder à la mise à jour, j’ai suivi les instructions du manuel pour une mise à jour manuel.
JE télécharge les fichiers depuis le site de Nextcloud, puis je lance la commance OCC UPGRADE.

Ce n’est pas la première fois que je fais une mise à jour mais c’est la première fois que j’ai une erreur comme ça.

Côté technique, je suis chez OVH sur un hébergement mutualisé.
Auriez-vous une idée ?

Merci d’avance

Salut,

Lorsque j’étais passé de 17 à 18, j’avais eu un problème similaire à cause de talk. La solution que j’ai trouvée était de désactiver talk, faire la MAJ de nextcloud puis réinstaller/activer talk après.

Merci Thom1, je n’ai plus accès à l’administration web de Nextcloud, un écran me dit que la mise à jour est en cours.

J’ai essayé de supprimer le dossier sur le FTP mais ça bloque aussi, le message d’erreur est alors le suivant :

UnexpectedValueException: The files of the app "workflowengine" were not correctly replaced before running the update
Update failed

Il y a peut-être une manière propre de désactiver l’extension que je ne connais pas.

As-tu accès à la ligne de commande? Si c’est le cas, tu peux essayer d’arrêter l’application avec la commande sudo -u <webuser> php occ app:disable désactiver le flux. Et désinstallez si nécessaire.

(translated with google and some rusty school-french)

Merci @JimmyKater, mais lorsque je taps

php occ app:disable workflowengine

J’ai le message d’erreur suivant :

You may use your browser or the occ upgrade command to do the upgrade
workflowengine can't be disabled.

C’est comme si Workflowengine était une partie de Nextcloud.

as-tu essayé de mettre à jour le workflowengine? … occ app:update workflowengine

As-tu tout de même tenter de lancer la commande ?
sudo -u <http user> php occ upgrade
Elle pourra peut-être réparer ton installation, il faudra juste réinstaller workflowengine après.

@JimmyKater je pense que je ne peux pas le faire pendant que la mise à jour est bloquée, j’ai ce message :

Nextcloud or one of the apps require upgrade - only a limited number of commands are available
You may use your browser or the occ upgrade command to do the upgrade

@thom1

Je n’ai pas d’accès sudo (hébergement mutualisé oblige) mais je tape bien php occ upgrade et c’est ce qui me génère une erreur.

Et visiblement la mise à jour est impossible sans Workflowengine.

  • Désactivation en ligne de commande : impossible sans mise à jour
  • Désactivation par suppression des fichiers : KO
  • Désactivation par l’interface web : impossible sans mise à jour

Tu n’as pas de sauvegarde à restaurer ?

Je dois avoir ça, je peux tenter. Je vois tiens au courant merci.

Il serait toujours possible d’essayer de créer manuellement les index manquants dans la base de données.

occ db:add-missing-indices

@JimmyKater la commande à fonctionné : psa de message d’erreur et des messages de confirmation mais j’ai eu le même message d’erreur ensuite.

Zut!
Peut-être que cela a quelque chose à voir avec l’utilisateur qui exécute la commande.
Tu dis que tu ne peux pas exécuter sudo … comment et où entres-tu les commandes?

J’ai un accès SSH au serveur, je peux exécuter les commandes habituelles mais je n’ai pas les droits administrateur comme je suis sur un serveur mutualisé.

J’ai l’impression d’avoir un peu avancé, je suis repartie d’une sauvegarde comme tu me l’as conseillé @Thom1

J’ai essayé de désactiver Workflow l’extension qui me cause du soucis, impossible, j’ai juste un message qui m’informe de l’échec de la désactivation.

La sauvegarde était en 18.0.0 j’ai donc appliqué les mises à jours 18.0.4 puis 18.0.6, sans problème et lors de la mise à jour vers la 19.0.0, j’ai de nouveau le même message d’erreur :frowning:

Je me réponds à moi même, ça a fini par fonctionné.
Devant le même problème que la semaine dernière, j’ai tenté la même solution (celle qui n’avait pas fonctionné) : https://github.com/nextcloud/server/issues/19058

Et là, magie, ça marche. J’ai quand même du passer par la ligne de commande plutôt que par l’interface web, j’ai du insister plusieurs fois, mais ça a fini par passer.

Ce qui me laisse perplexe, c’est le caractère aléatoire, je ne comprends pas pourquoi en faisant plusieurs fois la même chose, j’ai obtenu un résultat différent, j’ai peut-être fait une tout petite chose différemment et je ne m’en suis pas rendu compte.