Enterprise type install - Redis\haproxy\Nextcloud not working

While waiting for nextcloud support to answer - I will put this here in hopes someone may have similar setup and may be able to direct me to where the issue resides. Any thoughts or possible solutions appreciated.

Current Setup:
haproxy - outside IP (hidden) - inside ip
Hub Servers: - -
Redis Server:
Database Servers: - -
Database Proxysql:

Currently all backend services and nextcloud will work without my Redis server -
When enabling the redis server in the config.php I am getting the following error (first line)

":{“Exception”:“RedisException”,“Message”:“Redis server went away”,

It appears that when it is doing its redis connection it is attempting to talk through the haproxy server even though I have the config set to utilize the internal IP address 136 for the redis server.


‘datadirectory’ => ‘/var/www/html/nextcloud/data’,
‘dbtype’ => ‘mysql’,
‘version’ => ‘’,
‘overwrite.cli.url’ => ‘hidden’
‘overwriteprotocol’ => ‘https’,
‘dbname’ => ‘cloud’,
‘dbhost’ => ‘’,
‘dbport’ => ‘’, ‘hidden’
‘dbtableprefix’ => ‘oc_’,
‘mysql.utf8mb4’ => true,
‘dbuser’ => ‘oc_admin’,
‘dbpassword’ =>
‘installed’ => true,
‘memcache.local’ => ‘\OC\Memcache\APCu’,
‘memcache.distributed’ => ‘\OC\Memcache\Redis’,
‘memcache.lockfile’ => ‘OC\Memcache\Redis’,
‘Redis’ => array (
‘host’ => ‘’,
‘port’ => 6379,

No real idea. But perhaps Redis is not working. You can check the socket (ip:port) on your Redis-server. Also you can test Redis from outsite (your nextcloud server).

Read part " Check if Redis is working"

Ran a test internally from my haproxy and yes the redis server does respond and is accepting connections. This was still internal and not from outside of my LAN.

Maybe this is where the issue lies - the redis server is behind the haproxy without direct access from the internet to the redis server. I would need to pump it through haproxy, although not really sure how I would be able to do that properly.

As for redis responding it does from any server within my internal network. I am guessing that there may need to be something done within haproxy to properly route the redis traffic to and from the hub servers.Seeing as though it looks like nextcloud is attempting to access redis through the proxy.

I think you must test Redis from Nextcloud server. Is it your haproxy?

That was from the Nextcloud server – as I had explain in the first post the environment is large. In the post I laid out the different servers.

127 is the Nextcloud hub1 server 128 and 129 are the currently offline hub 2 and 3 servers.

They are being loadbalanced via reverse proxy with haproxy. Ha proxy server is .130

The Redis server is .136 – as configured in the config.php.


Just to close this out without too much embarrisment –

When setting up redis memcache - Ensure to capitilize the R on the first portion and lower case R on the next.

‘memcache.distributed’ => ‘\OC\Memcache\Redis’,
‘memcache.lockfile’ => ‘\OC\Memcache\Redis’,
‘Redis’ => array (

Was original - need to ensure \OC\Memcache\Redis’,

and redis’ => array (