Encryption won't work after filecache truncate

Nextcloud version (eg, 10.0.2): 11.0.1
Operating system and version (eg, Ubuntu 16.04): Debian 8.7
Apache or nginx version (eg, Apache 2.4.25): Apache/2.4.10
PHP version (eg, 5.6): 5.6.30

The issue you are facing:
Hi there,
I’m facing an issue with an nextcloud instance that has encryption enabled. Because of a few problems with the data-storage there existed a bunch of broken entrys in the filecache database. I tried to eliminate them with the command files:cleanup, but that didn’t worked for me. So I decided to truncate the filecache and rescan the data directory with files:scan. After this rescan my sync client began to freak out and started a download of all files. Ther reason for this was that all folders got marked as modified seconds ago. In addition to that the entrys in the database had all encrytion:0 so I wasn’t able to open one of them.
After this destaster I removed the filecache a second time and only started my sync client. This worked partly and the modified time was correct now, but not all files got listed and folders are complete empty in the webinterface. The files themselfes still exists in the data directory. My client thought now that the files aren’t there anymore and removed them from my computer.
Now I enabled maintenance mode and I have no idea. I hope that you have any tipps for me.

thanks in advance,

Information from the filecache-table is used to sign the encrypted files:

So deleting the filecache table makes it impossible to check the signature and restoring without the signature should be possible but isn’t possible yet.