Enable HTTPS quit with error

After set up my new nextcloud box i tried to enable https: Box is available from outside but enabling process quits with error:

ls: cannot access ‘/var/snap/nextcloud/48/certs/certbot/config/live’: No such file or directory

Any idea in this?

Thanks and KR



i have exactly the same problem :frowning:

Kind regards

Me, too :slight_smile:

  • Reachable from the outside
  • Updated according “Current issues
  • The following command shows the error:

$ sudo nextcloud.enable-https -d

What can we/I do?


Same issue with new arrived box today.

Have you met these requirements? (y/n) y
Please enter an email address (for urgent notices or key recovery): xxxxx@yyyyy.com
Please enter your domain name(s) (space-separated): validaddress.com
Attempting to obtain certificates... done
ls: cannot access '/var/snap/nextcloud/99/certs/certbot/config/live': No such file or directory
Restarting apache... done

I would cautiously say this is a permissions issue.


Thanks for the reports.
Since many people are affected, I would suggest to open an issue on Github. That way the maintainer will take a closer look.

Today simulation works and returns a success.

The real command stucks at restarting apache server. I had to login on a 2nd console and reboot the box. After this, it now works with ssl.

Still not working for me after a reboot.
It’s not an permissions issue, because the folder “live” (/var/snap/nextcloud/99/certs/certbot/config/live) does not exist on my Nextcloud Box.

ls -l /var/snap/nextcloud/48/certs/certbot/config/
total 16
drwx------ 3 root root 4096 Oct 14 16:01 accounts
drwxr-xr-x 2 root root 4096 Oct 15 10:41 csr
drwx------ 2 root root 4096 Oct 15 10:41 keys
drwxr-xr-x 2 root root 4096 Oct 14 16:02 renewal

There has been an update for the snap today can you check if your snap has been updated?

sudo snap refresh

–> All snaps up to date.


After “sudo snap refresh nextcloud”, it works now!
It is not enough only refresh ubuntu-core, as descibed in wiki Current issues

1 Like

Thanks sky2000, it seems all snaps need to be reinstalled after the update so that they can pick up the new security profiles