"Empty response from the server" Local linux folder

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): 22.2.0
Operating system and version (eg, Ubuntu 20.04): Lubuntu 20.04.3 LTS
Apache or nginx version (eg, Apache 2.4.25): Apache2 2.4.41
PHP version (eg, 7.4): /snap/nextcloud/current/bin -v doesn't show any version number.

The issue you are facing:

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. Try to attach a normal Linux folder tree as External Storage (Local), read-only and sharable, usable by user Files.
  2. Admin account shows red exclamation mark in the attach line, with no error message. It also says smbclient is not installed, even though I have installed it and it should not be needed for mounting an ordinary Linux folder tree.
  3. In a window logged in as the user for whom the attachment was created, (Files) message is “Empty response from the server”

The output of your Nextcloud log in Admin > Logging:

[no app in context] Warning: Login failed: FileSharer (Remote IP: 203.213.126.165)

POST /index.php/login
from 203.213.126.165 at 2021-11-16T00:50:56+00:00

[ocs_api] Error: Failed addUser attempt: User already exists.

POST /ocs/v2.php/cloud/users
from 203.213.126.165 by ltadmin at 2021-11-16T00:37:05+00:00

[ocs_api] Error: Unable to send the invitation mail to owner_langtran@sil.org

POST /ocs/v2.php/cloud/users
from 203.213.126.165 by ltadmin at 2021-11-16T00:37:05+00:00

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

For noobs like me it would help if someone can update the path in the question above. I found the file in
/path/nextcloud/htdocs/config/config.php. Here are the contents:

<?php

$snap_current = getenv('SNAP_CURRENT');
$snap_data_current = getenv('SNAP_DATA_CURRENT');

$CONFIG = array(
/**
 * Use the ``apps_paths`` parameter to set the location of the Apps directory,
 * which should be scanned for available apps, and where user-specific apps
 * should be installed from the Apps store. The ``path`` defines the absolute
 * file system path to the app folder. The key ``url`` defines the HTTP web path
* to that folder, starting from the Nextcloud web root. The key ``writable``
 * indicates if a web server can write files to that folder.
 */
'apps_paths' => array(
	/**
	 * These are the default apps shipped with Nextcloud. They are read-only.
	 */
	array(
		'path'=> $snap_current.'/htdocs/apps',
		'url' => '/apps',
		'writable' => false,
	),

	/**
	 * This directory is writable, meant for apps installed by the user.
	 */
	array(
		'path'=> $snap_data_current.'/nextcloud/extra-apps',
		'url' => '/extra-apps',
		'writable' => true,
	),
),

/**
 * Database types that are supported for installation.
 *
 * Available:
 * 	- sqlite (SQLite3 - Not in Enterprise Edition)
 * 	- mysql (MySQL)
 * 	- pgsql (PostgreSQL)
 * 	- oci (Oracle - Enterprise Edition Only)
 */
'supportedDatabases' => array(
	'mysql',
),

'memcache.locking' => '\OC\Memcache\Redis',
'memcache.local' => '\OC\Memcache\Redis',
'redis' => array(
    'host' => getenv('REDIS_SOCKET'),
    'port' => 0,
),

'log_type' => 'file',
'logfile' => $snap_data_current.'/logs/nextcloud.log',
'logfilemode' => 0640,
);

The output of your Apache/nginx/system log in /var/log/____:

Sorry, I'm having a hard time deciding which log to include from /var/log/apache2 .

Hello,
I am very impressed with NextCloud :slight_smile:
The snap installation worked very well. I have been able to set up clients on Windows and Mac that sync changes automatically from my NextCloud server on Lubuntu 20.04.3 LTS.
I am now trying to add the repository (described in my profile) , which is a normal Linux folder tree.
I used the instructions at https://docs.nextcloud.com/server/latest/admin_manual/configuration_files/external_storage/local.html
I used the NextCloud admin account ltadmin to set up the external storage (local), which is at
/data/LT/BTSync, sharing it to a user in the admin group, Files, read-only and sharable, giving it the name LTSync.
The window logged in as the administrator, ltadmin, shows the red exclamation mark and no error message, and also a message above the sharing details line

"smbclient" is not installed. Mounting of "SMB/CIFS", "SMB/CIFS using OC login" is not possible. Please ask your system administrator to install it.

I have installed smbclient, even though it should not be needed to mount a normal Linux folder.
When I use an incognito window to log in as the user the folder should be provided for, Files, and look at the folders available to that user, I see the folder LTSync. When I try to open it, however, I see the message

There was an error with message: Empty response from the server. Do you want to review mount point config in admin settings page?

Next I tried to share a test folder, from the /home filesystem instead of from the /data filesystem, where my repository is. This time the admin user got a green success icon :-), but when I looked at the folder with the user Files, I got the messages No files here and You don’t have permission to upload or create files here. But I didn’t want the user Files to create files there, just to share what other processes on the system had put there.

Next I changed the way the folder was shared, removing the read-only setting. This time Files found an empty folder and a Plus button for adding a file. Why couldn’t NextCloud see the files that were already in the shared folder tree?
So then I clicked the Plus icon and selected the option to make a new text document. When I selected Blank Template I got the message Unable to create new file from template.

It seems the system for External storage (Local) is rather broken.
And it would really help if the red exclamation mark showed the real error.
Is there any way we can refer these matters to developers?
Or perhaps it’s the documentation that is not up-to-date?

Thanks for thinking about this,
Jim