Email share notification - can't change language to german

Nextcloud version: 11.0.1 (stable) |
OS: Debian 8.6
PHP 5.6.29-0+deb8u1 (cli)

’default_language’ => ‘de’,

personal language is german (du)


since i’ve updated from 10>11 or 9>10 (can’t remember) im facing the problem with the language used in the mails when sharing files or folders.
All kind of mails are send in english instead of german. It’s driving me crazy :frowning:

did i miss some info for you? nobody a clue? :cry:

I have the same problem.
Nextcloud version: 11.0.2 (stable) and config.php file have 'default_language' => 'it', but email notification are in english language.

how to solve it?


Could anybody from the devs please give an answer for this problem?
i would like to know if can fix this or do i have to do a clean install.



I receive notifications in German. So in general there is a way to have these mails in your language.
Did you guys define your(!) personal language in your user settings? In the top right, click your profile picture and select “personal”/ “persönlich”, scroll down to “Language”/ “Sprache” and select the language you want. I guess this is where you define the language for your notification mails.

Hope this helps.

Best regards

yes i set the personal language and the system language to englisch but the mails are still in englisch…

Hi @Sub7dll ,

Is this still an issue for you? While no-one else answers here, I try to do my best to help further.
Most import however is to receive more information regarding the problem.

What exactly are your steps to share a file/ folder, where the mail notification is in english?

What apps are activated on your server?

Do you use the app “mail template editor”? (Editing of the templates might be necessary)

Do you use the app “share by mail”? (I don’t know maybe this only supports english mails)

Please provide the Nextcloud logs after a notification mail has been sent.

While it seems you set up your server correctly with defining the correct language in the user profile and default language in the config.php it could be that an app got a problem. I once fixed a strange problem by disabling and re-enabling the app again. Maybe this is something that might work here as well. So you could either try to disable some apps, that might interfere here and overwrite the default behavior of NC (as said, it works on my machine) and test again with notification mails. Or or disable and re-enable the default NC apps, that are relevant for sharing and notification. Careful however, disabling the sharing app will cause ALL share to be reset. Which means you have to share all files/ folders after re-enabling the app again.

Hi @Schmu ,

it was still an issue for me until now. Its finally working with share notification mails in german language.
I’m not sure what actually did the fix for this problem because i was fixing a second problem (Web Updater was giving me an error when Downloading the update -> “Curl error: SSL certificate problem: self signed certificate in certificate chain” and “Parsing response failed”) at the same time.

I did the following changes:

  •      disabling and re-enabling following apps: Comments, Mail template editor, Notifications, Share by mail
  •      fixed the curl error and did the update over web updater to Nextcloud 11.0.2

After the update to 11.0.2 change a the personal language again and shared an folder -> the share notification mail was now in german.

Thank you for your hints with re-enabling apps!

Have a nice day =)

I’m glad to read it’s working now :slight_smile:

Have a nice day as well