[EDIT: Solved] Nextcloud 13 Stable Strange Webdav Error on File Upload with Mountain Duck/Windows Explorer

Hey guys,

Have a question here and wanted to see if anyone else is experiencing the same thing or if I’ve encountered something unknown and unexpected. I’ve got my HTTPS Nextcloud 13 stable server remotely mounted using MountainDuck via WebDAV.

It’s sometimes a little slow, but generally works just fine. However, poking through logs today I noticed that seemingly every time I upload a file to Nextcloud via the MountainDuck integration with Windows Explorer I see the following error in my Nextcloud WebGUI logging:

Fatal webdav InvalidArgumentException: X-OC-MTime header must be an integer (unix timestamp).

And below that there is what appears to be a small stack trace saying the following:

  1. /var/www/nextcloud/apps/dav/lib/Connector/Sabre/Node.php - line 168: OCA\DAV\Connector\Sabre\Node->sanitizeMtime(‘Tue, 06 Feb 201…’)

  2. /var/www/nextcloud/apps/dav/lib/Connector/Sabre/FilesPlugin.php - line 415: OCA\DAV\Connector\Sabre\Node->touch(‘Tue, 06 Feb 201…’)

  3. /var/www/nextcloud/3rdparty/sabre/dav/lib/DAV/PropPatch.php - line 278: OCA\DAV\Connector\Sabre\FilesPlugin->OCA\DAV\Connector\Sabre{closure}(*** sensitive parameters replaced ***)

  4. /var/www/nextcloud/3rdparty/sabre/dav/lib/DAV/PropPatch.php - line 243: Sabre\DAV\PropPatch->doCallBackSingleProp(’{DAV }lastmodif…’, Object(Closure))

  5. /var/www/nextcloud/3rdparty/sabre/dav/lib/DAV/Server.php - line 1266: Sabre\DAV\PropPatch->commit()

  6. /var/www/nextcloud/3rdparty/sabre/dav/lib/DAV/CorePlugin.php - line 385: Sabre\DAV\Server->updateProperties(‘Shared/Dave-PC/…’, Array)

  7. [internal function] Sabre\DAV\CorePlugin->httpPropPatch(Object(Sabre\HTTP\Request), Object(Sabre\HTTP\Response))

  8. /var/www/nextcloud/3rdparty/sabre/event/lib/EventEmitterTrait.php - line 105: call_user_func_array(Array, Array)

  9. /var/www/nextcloud/3rdparty/sabre/dav/lib/DAV/Server.php - line 479: Sabre\Event\EventEmitter->emit(‘method PROPPATC…’, Array)

  10. /var/www/nextcloud/3rdparty/sabre/dav/lib/DAV/Server.php - line 254: Sabre\DAV\Server->invokeMethod(Object(Sabre\HTTP\Request), Object(Sabre\HTTP\Response))

  11. /var/www/nextcloud/apps/dav/appinfo/v1/webdav.php - line 80: Sabre\DAV\Server->exec()

  12. /var/www/nextcloud/remote.php - line 164: require_once(’/var/www/nextcl…’)

  13. {main}

Anyone smarter than I have any idea whether this is something expected with WebDAV, expected with MountainDuck and the way it works, not-expected, or something else entirely? Many thanks!!

EDIT: Did some further troubleshooting and remembered testing NetDrive back in the day. Tried that and low and behold it doesn’t produce the log error in Nextcloud when uploading - so this appears to be a MountainDuck induced error, rather than Nextcloud. Just FYI for anyone in the future in case they happen across a similar issue. Thanks!

1 Like