DS216play new HDD drives, Nextcloud not working

The issue you are facing: I replaced the HDD in my Synology DS216play, as one drive had failed sectors. Then i swapped the first one and everything worked, but as i swapped the second one Nextcloud stopped working. Do i need to reset the rights? Or is it a setup issue on the NAS?
Sorry i am a very basic user and hardly managed to configure everything right in the beginning…

Is this the first time you’ve seen this error? (Y/N): yes

Are you supposed to change a drive and the system manages everything automatically? This might be a better question for the synology community first, if the new disk was recognized correctly. Not sure if the data is supposed to be there or has to be manually copied back from a backup.
If you are using RAID, and you change one disk, you have to wait until all the data are synchronized over all RAID disks before you change a second drive.

that’s what i expected and the behavior for the first drive. The mirroring from the RAID worked automatically. Therefore i assumed it would just work. But it didn’t, even though all the data is there, only Nextcloud doesn’t work. There are some new folders like etc.defaults and var.defaults, but i don´t know why it is not working…

If the Nextcloud data is there, it would be interesting to see the log files. Perhaps something is missing or just the database isn’t loaded etc. There are many options.

Nginx log:
021/11/25 21:44:13 [error] 25088#25088: *766 connect() to unix:/run/synoscgi_socket.sock failed (111: Connection refused) while connecting to upstream, client: IPprivat, server: _, request: “GET //synoscgi.sock/socket.io/?SynoToken=aTq2Tjj1uJz2M&UserType=user&EIO=3&transport=polling&t=NrOrrpU HTTP/2.0”, upstream: “http://unix:/run/synoscgi_socket.sock:/socket.io/?SynoToken=aTq2Tjj1uJz2M&UserType=user&EIO=3&transport=polling&t=NrOrrpU”, host: “IPprivat”, referrer: “https://IPprivat1/
2021/11/25 21:52:32 [error] 11837#11837: *70 upstream prematurely closed connection while reading response header from upstream, client: IPprivat, server: _, request: “POST /webapi/entry.cgi HTTP/2.0”, upstream: “scgi://unix:/run/synoscgi.sock:”, host: “IPprivat”, referrer: “https://IPprivat/

021-11-24T14:33:33+01:00 ZZZZZZZ AH00558: httpd24: Could not reliably determine the server’s fully qualified domain name, using Set the ‘ServerName’ directive globally to suppress this message

2021-11-24T14:33:33+01:00 ZZZZZZZ [Wed Nov 24 14:33:33.793706 2021] [mpm_worker:notice] [pid 10135:tid 1996347808] AH00292: Apache/2.4.46 (Unix) configured – resuming normal operations

2021-11-24T14:33:33+01:00 ZZZZZZZ [Wed Nov 24 14:33:33.820135 2021] [core:notice] [pid 10135:tid 1996347808] AH00094: Command line: ‘/var/packages/Apache2.4/target/usr/local/bin/httpd24’

Those are some of the error logs. Do they help? Sorry i am not too experienced :slight_smile:

I am not sure how exactly the things are set up in synology. It can be:
webserver proxy (nginx) <-> webserver nextcloud (within container perhaps??), apache <-> php-fpm

the webserver proxy is often used when you run stuff in virtual environment (virtual servers, container etc). This synoscgi_socket could be a way to connect php to your webserver (like the php-fpm in linux). But I have not idea at all. Perhaps some webserver or other service is just not running.
But you don’t get so far to get any Nextcloud specific errors.