Downloads stop at 512 MB. Unclear Problem. But Uploads work GREAT?

Deleted. Put in personal information.

Problem solved:

Pointed a reverse proxy at an Apache version of Nextcloud. I think there were some problems using Nginx as the webserver.

Just too add a few more details.

I have a SMB share mounted via external storage plugin at / in Nextcloud. So I think I resolved the SMB errors by creating the missing foldter in /var/www/.cache/SMB an CHOWN to wwwdata.

I’m using NGINX as the webserver. I’ve added all of the possible settings in PHP config and NGINX configs to allow large file transfers that I can find, anywhere :). Not changes. I can upload large files to Nextcloud, but anytime I download, the download stops at 512 MB.

I increased PHP memory limit to 2 GB.

I’m not sure how to check my temp folder size, but df -h doesn’t show any mount locations ~512 MB, and diskpace in all of the expected locations is fine.

This SMB share I use regularly for storing, transferring large files of several GB. It seems to otherwise behave normally.

No idea what the problem is. It seems like there’s a default setting somewhere that I can’t find, that needs to be changed.

I had a similar problem, but without permission errors in log files.

Do you have an reverse nginx proxy in front of your nextcloud server?

If so, you can put parameter “proxy_max_temp_file_size 0;” after your proxy_pass block in the reverse nginx config file. It helped me with download of big files.

1 Like

Put an Nginx proxy in front of nextcloud server, reinstalled Nextcloud with an Apache webserver. Everything is working much better.

NAME=“Ubuntu”
VERSION=“20.04.4 LTS (Focal Fossa)”
Proxy Reverse Nginx + Apache Nextcloud

sudo apt install libsmbclient-dev
sudo apt install php7.4-smbclient
sudo a2enmod proxy_fcgi setenvif
sudo a2enconf php7.4-fpm
sudo service apache2 restart 

:+1:

I am running nginx also. I found this page with a fix: https://github.com/nextcloud/server/issues/31308

I ran:
sudo apt install php7.4-smbclient
sudo systemctl restart apache2 php7.4-fpm

and it works.