Downloading and browsing at the same time using HTTP2 not possible

Hello everyone,

this is my current setup:

Nextcloud version: 12.0.5
Operating system and version: Debian 9 "stretch"
Apache version: 2.4.25 (using HTTP2)
PHP version: 7.0 (using FPM)

I am not able to download a large file and browse Nextcloud at the same time.

It should be easy to reproduce: Download a large file and then click around in your Nextcloud, nothing should happend, Nextcloud is not responding to any request. After the download is finished, I am able to browse Nextcloud again.

There are two ways which allow me to download and browse at the same time:

  1. Disable HTTP2 in Firefox using about:config and set network.http.spdy.enabled.http2 to false.
  2. Disable HTTP2 in Apache’s configuration via a2disconf http2

Am I doing something wrong or are you also facing this issue?

Try using a different browser.

Google Chrome and Microsoft Edge also are facing this issue. I could only find 2 working browsers / clients:

  • GNOME’s built in web browser (which is a very simple one)
  • curl

I have found the solution, it was my fault. I forgot to enable the Apache mpm_event module after a server migration a time ago so even HTTP2 connections could only handle one request at time.

a2dismod mpm_prefork
a2enmod mpm_event
systemctl restart apache2