Downloading a file from nextcloud stops at exactly 2.7GB


I am running Nextcloud 12.0.4 on Debian 8.10 on Odroid XU4 (
I’ve managed to upload on file (using client) which is 6.7GB in size.
But I cannot download the complete file - I always get 2918700920 bytes (tried with wget, curl and chromium)

I can’t see a single indicator whats going wrong in the logfiles, although my logging level is set to debug (in apache, php and nextcloud).

The strange thing is that when trying to resume download with wget, it halts and does not download a single bit past 2918700920 bytes :slight_smile:

Any ideas?

On which device / OS / filesystem you’re trying to save? Rough guess 32 Bit?

I tried to download from the server itself (with wget and curl) and from 64bit Debian (with wget, curl and chromium).

On the server copying the file using command line (cp) works just fine.
I also can download from the server using scp just fine.

The server:
root@host# lscpu
Architecture: armv7l
Byte Order: Little Endian
CPU(s): 8
On-line CPU(s) list: 0-7
Thread(s) per core: 1
Core(s) per socket: 4
Socket(s): 2
Model name: ARMv7 Processor rev 3 (v7l)
CPU max MHz: 1400,0000
CPU min MHz: 200,0000
root@host# cat /etc/debian_version
root@host# uname -a
Linux purk 4.9.61+ #1 SMP PREEMPT Sat Nov 18 15:15:45 UTC 2017 armv7l GNU/Linux
root@host# dpkg --print-architecture
root@host# getconf LONG_BIT
root@host# arch

I have just tried that downloading from apache directly works just fine.

mm okay than I would check in /etc/php/7.0/apache2/php.ini and would play with memory_limit and max_execution_time if it helps…

Thanks for tips.

But unfortunately no dice ;(

Sorry than I do not have a quick solution. Passing the puck…