Downloaded files are empty or don't show their content modifications

Hi, and so many thanks for that great app that save hours of our (small) team coordination… and tons of mails :slight_smile:

Here is a problem, not sure for a bug, it seems mostly like a configuration problem. But we don’t see what.

For bug reports, provide the steps to reproduce and if possible a minimal demo of the problem:

  1. Upload or create a docx or xlsx document.
  2. Edit it online, make some modifications, save it, quit.
  3. Reopen online document, modifications are still here, ok \o/ :slight_smile:
  4. Download the modified document on the local pc.
  5. Open the local document on the local pc : modifications are not here :-/
  6. When exporting online document to PDF, pdf file is blank-emplty :-/

This is running on a shared web hosting linux system. The installation of Community Document Server 0.1.12 and ONLYOFFICE 7.3.2 has been done on Nextcloud Hub II 23.0.4 following the classical Nextcloud Applications search / install / activate method.

No manual modification at file system level (config.php or whatever) has been done.

We’ve tried lots of configuration possibilities in Parameters > ONLYOFFICE > Paramètres du serveur (spaces in https:// because new forum users can’t post with more than 2 links) :

  • Adresse du ONLYOFFICE Docs : h t t p s ://
  • Désactiver la vérification du certyficat (non sur) : unchecked
  • Clé secrète (laisser vide pour désactiver) : empty
    Paramètres avancés du serveur
  • Adresse du ONLYOFFICE Docs pour les demandes internes du serveur : h t t p s ://
  • Adresse du serveur pour les demandes internes du ONLYOFFICE Docs :

Even running with ONLYOFFICE Docs demo. Same behavior, modifications done on online documents are not presents in the downloaded files.

Following this documentation : Integration. Getting Started. Nextcloud - ONLYOFFICE we don’t find any light to our problem.

We found that : Starting from version 4.3.0, ONLYOFFICE Docs and Nextcloud can be installed either on different computers or on the same machine. In case you select the latter variant, you will need to set up a custom port for ONLYOFFICE Docs, as by default both ONLYOFFICE Docs and Nextcloud work on port 80.

The installation is on the same machine (shared web hosting) and we guess the problem is around the communication between ONLYOFFICE and Nextcloud but we don’t know where to seek, set or test something.

We hope someone in this forum could help us to solve it.

Document Server version: Community Document Server 0.1.12
Connector version: ONLYOFFICE 7.3.2
DMS (platform) version: Nextcloud Hub II 23.0.4
OS: Linux 5.15.32-alwaysdata x86_64 on shared web hosting (no access to /etc /usr and so)

  • Version : 7.4.8
  • Limite de mémoire : 512 MB
  • Temps d’exécution maximal : 3600
  • Taille de téléversement maximale : 256 MB
  • Type : mysql
  • Version : 0.4.22
  • Taille : 19 MB
    Browser version: Firefox 91.8.0esr (64 bits) under Debian 11
    Browser version: Firefox 99.0.1 (64 bits) under Windows 10 Pro 21H2
    Browser version: Vivaldi 5.2.2623.41 (Stable channel) (64 bits) under Windows 10 Pro 21H2
    Attach logs if possible: Here are some logs copied from Paramètres > Journalisation, but not sure it is relevant.

Erreur core OC_Image::fixOrientation(): No image loaded 2022-04-29T09:44:54+0200

Erreur PHP Error: ZipArchive::getStream(): Invalid or uninitialized Zip object at /home/wishnoo/sites/ 2022-04-29T09:44:54+0200


OC\Log\ErrorHandler::onError(2, "ZipArchive: ... t", "/home/wishn ... p", 154, { path: "Thu ... "})

/home/wishnoo/sites/ - line 154:


/home/wishnoo/sites/ - line 42:

OC\Archive\ZIP->extractFile("Thumbnails/thumbnail.png", "/home/wishn ... D")

/home/wishnoo/sites/ - line 44:

OC\Preview\Bundled->extractThumbnail(OC\Files\Node\File {}, "Thumbnails/thumbnail.png")

/home/wishnoo/sites/ - line 62:

OC\Preview\OpenDocument->getThumbnail(OC\Files\Node\File {}, 4096, 4096)

/home/wishnoo/sites/ - line 245:

OC\Preview\GeneratorHelper->getThumbnail(OC\Preview\OpenDocument {}, OC\Files\Node\File {}, 4096, 4096)

/home/wishnoo/sites/ - line 140:

OC\Preview\Generator->getMaxPreview(OC\Files\Sim ... {}, OC\Files\Node\File {}, "application ... t", "")

/home/wishnoo/sites/ - line 109:

OC\Preview\Generator->generatePreviews(OC\Files\Node\File {}, [ { width: 2 ... }], "application ... t")

/home/wishnoo/sites/ - line 212:

OC\Preview\Generator->getPreview(OC\Files\Node\File {}, 250, 250, true, "fill", null)

/home/wishnoo/sites/ - line 169:

OC\PreviewManager->getPreview(OC\Files\Node\File {}, 250, 250, true, "fill")

/home/wishnoo/sites/ - line 142:

OC\Core\Controller\PreviewController->fetchPreview(OC\Files\Node\File {}, 250, 250, false, false, "fill")

/home/wishnoo/sites/ - line 217:

OC\Core\Controller\PreviewController->getPreviewByFileId(4152, 250, 250, false, false, "fill")

/home/wishnoo/sites/ - line 126:

OC\AppFramework\Http\Dispatcher->executeController(OC\Core\Cont ... {}, "getPreviewByFileId")

/home/wishnoo/sites/ - line 157:

OC\AppFramework\Http\Dispatcher->dispatch(OC\Core\Cont ... {}, "getPreviewByFileId")

/home/wishnoo/sites/ - line 302:

OC\AppFramework\App::main("OC\\Core\\C ... r", "getPreviewByFileId", OC\AppFramew ... {}, { _route: "c ... "})

/home/wishnoo/sites/ - line 1008:


/home/wishnoo/sites/ - line 36:


I’ve made my answer here : File changes are shown in OnlyOffice but don't appear in Files app · Issue #12 · nextcloud/documentserver_community · GitHub
So the problem is not solved, but I’ve got a solution :wink: