Does the desktop client 2.5 running on OS X support TLS v1.1 and v1.2?

Does the desktop client 2.5 running on OS X support TLS v1.1 and v1.2? I can not connect to my server, which does not provide TLS 1.0, but i can connect via the owncloud-client.

Regards,
A.

There is an old topic on the theming bug tracker:

This topic is closed, the new packages are hopefully built to support newer TLS versions but Iā€™m not sure, I couldnā€™t find a current changelog. It would be kind if someone on a Mac could verify and confirm or submit a bug report.