DocumentServer not working

Hello everyone in the community. I would like first to thank all the Nextcloud developers for their wonderful work.

The Community Document Server app has not worked for a few days. Before it worked perfectly. The only change I have made is enabling an SSL certificate with LetsEncrypt and updating to version 22 of Nextcloud.

I have tried repeatedly to install and uninstall the app without any success, the Community Document Server still does not work.

Is there a solution for it?

Might I suggest installing your own version of the document server? Docker Hub

The Community Document Server app is notoriously poor, outdated and has problems. I wouldn’t trust it with any work you’re not willing to lose.

I have the same problem. On non of the NC installations is OnlyOffice working.
With some the document is not opened, but offered for download.
With others there is an error displayed. The doc could not be downloaded.
OnlyOffice works as this mesages are displayed on top of the OnlyOffice desktop.
Clicking the OK button in the error does not work. Chrome or Firefox, no difference.
Updating from 22.1.1 to 22.2.0 has no effect.
I could not find relevant error in various logs.
NC security is 100% ok.

So what is now causing these troubles? My clients are not happy …

Or is there a minimal new version of OnlyOffice relevant? My instance is working, with SSL on a separate server.

Same here, was working right until v22, since upgrade no more Community Server, just a blank page every time I try to open a document.

OK. It seems that older OnlyOffice (containers) (2019) do not work anymore.

Since I’m not an expert in updating containers, I’ve done this:

I installed portainer-ce on my Debian system (https://docs.portainer.io/v/ce-2.9/start/install/server/docker/linux)
I then installed the Watchtower container (https://www.youtube.com/watch?v=BXi3VjQt5ts)
Then I selected the option ‘recreate’ WITH ‘Pull latest image’ activated (not default).

After that actions, the OnlyOffce container works again.

NC should mention the minimal version recuired !

And these actions above will ensure me that alle container updates will be done automaticly. That was my lesson.

Hello everyone, thanks for your answers.

How I could solve the error was installing a fresh Nextcloud and installing the Community Document Server app.