Documents not being saved when editing. Nextcloud 18 | Local Community document server plugin

I’ve got the same issue. It looks like 2 people are editing the file (both my user), but it’s only open in one browser tab.

Dear All,

same issue here. Are there any solutions availiable yet? I´m on Debian Buster, NC18.02 and the latest DCS and OO Versions. All installed directly on my server, no Docker. And even after

Documents aren´t saved in Nextcloud.

I tried a lot. It´s really fustrating, but I don´t want to complain too much. It´s Open Source Software and all the participating developers have done a great job over the last years.
Nevertheless I hope there will be a solution soon. Online collaboration never has been more important than in these times.

Best Regards

1 Like

So is this working for some people at least? If yes, how did you manage it?

There are some suggestions about disabling the files versions, which even if it did work and from the comments it seems it doesn’t, is not a viable solution for me either since losing versions of files would lose me a pretty big securty net.

I’m just a simple home user that managed to set this up and have no idea where to even start if I wanted to contribute to a solution for this.

At this point it seems I simply have to stop using onlyoffice altogether.

I have exactly the same issue. I have a document that I opened today, and now it says 3 of me are editing it (it’s only me). It never syncs back to the docx file. Disabling versioning is not an option.

I do have memcache. Disabling that is also not an option as the server then slows to a crawl.

I think you should follow the issue on Github, we’re not the only ones to have the issue :frowning:

1 Like

Does anyone know if the Nextcloud devs are already aware of this? And how long bugfixes usually take? :slight_smile:

I understand that this is free software and it comes with no guaranty or whatsoever, but since the hub (including the office features) is the major promoted feature of V18 (and it’s not really usable like this) it is really in Nextclouds own interest to have this fixed asap.

1 Like

18.03 out now. And still no fix for this issue. What the heck is the difference between my installation and all the ones which seem to work perfectly?
Best Regards


I have also the 18.03 and I have the same issue.
Now I have temporary deactivate the OnlyOffice App. It is very dangerous if the user believes to save the data. If the user then accesses via WebDAV, the changes are not present. Can be very bad …

Is there an official bug channel at nextcloud?


I have searched in the bug list, but I have not found. Now I have created a bug issue:

I hope it helps.

And I closed the report. A link to a GitHub issue has been posted to this thread earlier.

?! Where is the last issue report? Could you please reopen the thread on Github or provide the link to the actual issue thread?

COVID-19 ensures we are all being socially isolated. Nobody can congregate, or co-ordinate, or mobilize into contrarian groups to work against the censorship or martial-law-by-any-other-name.

Now one of Nextcloud’s primary functions is disabled and no Devs even mention a fix or an ETA . Are you frickin’ kidding me?

Why cant we just roll-back or downgrade the Onlyoffice App to the previous working version ? Where’s the instructions for that.

I can confirm it’s very bad. I’m a user and yesterday I lost the last week of work. Any chances I can retrieve some of it?

It seems that setting the background job from cron.php back to Ajax solved the issue for me. Nextcloud 18.03 and OO 5.50 (docker)

One work around is to install documentserver in another host. I have done it, it works.
I strictly followed the instruction on onlyoffice to install the docker version of only documentserver (not communityserver). It’s quite straight forward.
The « tricky » part is to have all the ssl correctly setup. Both host must communicate without error on https. The best way to check is to use curl (without of course -k).

Not really stable workaround, sorry. Still having problems. Changed to Collabora. That worked.

Dear all, I had also the same problem but I found a possible explaination, and a workaround that is working for our installations.
Obviously feel free to not agree :slight_smile: this is my personal explanation I found to myself but it is also working for us in a predictable way.

At the start of the editing of a document with OnlyOffice and during all the time there is a session alive with a user potentially working on the document, the doc itself is managed in a temporary storage area (database or similar). This is because the filesystem is not good for multi-user, collaborative, editing. The document is written back to the filesystem only onces all the users that are editing it have finished their work and closed the online editor.
Until NC recognize there is a session alive, the document is not written back to filesystem.

Because the current NC graphical interface is not able to understand or to communicate to Only Office Community Server that a user has left the editor (possible bug or desired behaviour -> see later for Ajax explanation), the only moment when the “zombie” sessions are analyzed from the server and reaped in case the user left the editor is at cron execution.

So if you (as me) use a cron with the same configuration suggested in the official documentation (e.g. */5 * * * *) it means that the pending sessions will be reaped and the document will be saved only 5 minutes after the last user closes the editor.

What I did? I just changed the cron to execute each minute (* * * * *) and I have now the document saved 1 minute after the last connection to the document.

I haven’t tryed to switch to Ajax cron in production because in our environment it is not fitting our requirements, but I would imagine that with Ajax you will not experience such a problem because the “cron batches” are executed at each Ajax request.

So my conclusions and suggestions are:

  • if you are using desktop sync/webdav network mappings and “offline” editing from your pc, and you use crontab to execute batch commands, try to adopt more frequent cron executions
  • if you are using the online editor and most of the time you work with the Web UI, well you may tell us if Ajax cron is mitigating the problem described in this topic.

Just for your information, we are executing NC 18 on Ubuntu 18.04 LTS using as database MariaDB 10.3 with Galera enabled for HA.

Hope to have provided a reasonable idea and support to all of you.
Best Regards

Thanks for your feedback !

Do you know if there are some limitations/drawbacks to set a cron to execute each minute instad of 5 ?

I’m testing this workaround given by @depasqualedavide with cron job each minute. I have around 20 users and I do not detect an appreciable overhead.

I did also in Cron with * * * * * php -f /var/www/html/cron.php
It works but in the logging I have a Error: OC\User\NoUserException: Backends provided no user object

OC\User\NoUserException: Backends provided no user object

  1. <>OC\Files\Node\Root->getUserFolder(null)
  2. /var/www/html/lib/private/Files/Node/LazyRoot.php - line 65: call_user_func_array([ OC\Files\N … "], [ null])
  3. /var/www/html/lib/private/Files/Node/LazyRoot.php - line 282: OC\Files\Node\LazyRoot->__call(“getUserFolder”, [ null])
  4. /var/www/html/apps/ransomware_detection/lib/Monitor.php - line 140: OC\Files\Node\LazyRoot->getUserFolder(null)
  5. /var/www/html/apps/ransomware_detection/lib/Events/FilesEvents.php - line 122: OCA\RansomwareDetection\Monitor->analyze([ “/Documents/Test20.docx”], 3)
  6. /var/www/html/apps/ransomware_detection/lib/Events/FilesEvents.php - line 86: OCA\RansomwareDetection\Events\FilesEvents->analyze([ “/Documents/Test20.docx”], 3)
  7. /var/www/html/apps/ransomware_detection/lib/FilesHooks.php - line 79: OCA\RansomwareDetection\Events\FilesEvents->onFileWrite({ run: true, … "})
  8. /var/www/html/lib/private/legacy/hook.php - line 111: OCA\RansomwareDetection\FilesHooks::onFileWrite({ run: true, … "})
  9. /var/www/html/lib/private/Files/View.php - line 1275: OC_Hook::emit(“OC_Filesystem”, “post_write”, { run: true, … "})
  10. /var/www/html/lib/private/Files/View.php - line 1203: OC\Files\View->runHooks([ “update”,“write”], “/Documents/Test20.docx”, true)
  11. /var/www/html/lib/private/Files/View.php - line 694: OC\Files\View->basicOperation(“file_put_contents”, “/LiviuP/fil … x”, [ “update”,“write”], null)
  12. /var/www/html/lib/private/Files/Node/File.php - line 71: OC\Files\View->file_put_contents("/LiviuP/fil … x", null)
  13. /var/www/html/apps/documentserver_community/lib/Document/DocumentStore.php - line 163: OC\Files\Node\File->putContent(null)
  14. /var/www/html/apps/documentserver_community/lib/LocalAppData.php - line 100: OCA\DocumentServer\Document\DocumentStore->OCA\DocumentServer\Document{closure}("*** sensiti … *")
  15. /var/www/html/apps/documentserver_community/lib/Document/DocumentStore.php - line 164: OCA\DocumentServer\LocalAppData->getReadWriteLocalPath(OC\Files\Sim … {}, Closure {})
  16. /var/www/html/apps/documentserver_community/lib/Document/SaveHandler.php - line 56: OCA\DocumentServer\Document\DocumentStore->saveChanges(3281405952, [ OCA\Docume … }])
  17. /var/www/html/apps/documentserver_community/lib/BackgroundJob/Cleanup.php - line 69: OCA\DocumentServer\Document\SaveHandler->flushChanges(3281405952)
  18. /var/www/html/lib/public/BackgroundJob/Job.php - line 79: OCA\DocumentServer\BackgroundJob\Cleanup->run(null)
  19. /var/www/html/cron.php - line 125: OCP\BackgroundJob\Job->execute(OC\BackgroundJob\JobList {}, OC\Log {})