Document changes do not affect downloadable file

Following behaviour… I create a new file (docx, pptx, …), then open it in ONLYOFFICE, apply some changes, go back to file storage. If I reopen the file in ONLYOFFICE, I can see all changes, but the file savd in the file storage is not changed, i.e. if I download the file from the filestorage folder, I get the blank new unchanged file. If I open the file again in ONLYOFFICE and download the file from there, I get the correct version with all changes…

Please, could someone point me into the right direction?

Best regards & thanks in advance
Joerg

EDIT: forgot to mention… I’m using a univention server 4.4-0errata142 with nexcloud 15.0.7-0 and onlyoffice 5.2.4.94

I have seen this happen with one of our instances. What I found that after you make the changes to your document, refresh the page that Nextcloud is opened in, then download the file again. That has worked for me in the past. I don’t know if it is how the pages are cached, a browser cache, or what. I am assuming there is something on be backend of NC that isn’t updating the page once OO is done with it.

thanks a lot for your reply! I’ve tried as suggested, and to be honest… it’s a bit weird… if I change the document, I’am notified that it is saved automatically… then, going back to the folder, I see that the document was changed some time ago, but not “a few minutes” ago… waiting some time and refreshing the browser, seems to work then, but - to be honest - this workflow feels a bit “fragile” to me, and I’m afraid of problems when editing a document together with other users (since we talk about a collaboration tool!) and finally getting the correct version… I will keep on trying and I will provide an update here.

In the meantime, does anyone know what I can check… logs/certificates/webserver/caching/… whatsoever!? :wink:

Cheers
Joerg

Ok, seems, that with the latest updates and clean up of my installation I have at least a repeatable behaviour, i.e. one has to be a bit patient … ‘wait some time’ … until the document is marked “changed a few miutes ago”, but it works!

To me, it seems a bit odd, that the document on NC is not updated, as long as the document is opend in OO by a user… isn’t it possible to save intermediate versions back to NC even if the document is still open in OO? THat would help a lot!