Docker Onlyoffice Mixed Content Fehler

Hallo,
leider habe ich gerade ein Problem mit meiner Nextcloud und onlyOffice, vielleicht kann mir jemand weiterhelfen?

Ich habe nginx auf einem Ubuntu 18.04 und Nextcloud als Docker laufen, die docker-compose.yml findest du im Anhang.
Was ich durchgefĂŒhrt habe: docker compose up

Wie hier beschrieben wurde: pastebin.com/ZZbFzGpV

Generell funktioniert nextcloud selbst wunderbar, jedoch funktioniert die Implementierung von onlyOffice nicht.

Die “Serviceadresse der Dokumentbearbeitung” habe ich innerhalb von Nextcloud unter Einstellungen->onlyOffice bereits angepasst.

Jedoch wird beim öffnen eines Dokuments etc. folgendes angezeigt: “Unbekannter Fehler.”

Und in der Konsole: Mixed Content: The page at 'url.com/apps/onlyoffice/119?filePath=%2FTabelle.xlsx’ was loaded over HTTPS, but requested an insecure XMLHttpRequest endpoint ‘http://*.*..:8070/apps/documentserver_community/open/3622018858/Editor.bin’. This request has been blocked; the content must be served over HTTPS.

Ziel ist es fĂŒr meine Kommilitonen eine bessere Plattform als OneDrive zu schaffen.

docker-compose.yml:

version: '3'

services:

    nextcloud-db:
    image: mariadb
    container_name: nextcloud-db
    restart: always
    hostname: nextcloud-db
    environment:
        MYSQL_ROOT_PASSWORD: rootPassword
        MYSQL_DATABASE: nextcloud
        MYSQL_USER: user
        MYSQL_PASSWORD: passowrd
    volumes:
        - /home/mike/Dokumente/docker-nextcloud/nextcloud-db:/var/lib/mysql

    nextcloud:
    image: nextcloud
    container_name: nextcloud
    restart: unless-stopped
    ports:
        - 8070:80
    volumes:
        - /home/mike/Dokumente/docker-nextcloud/nextcloud:/var/www/html
    depends_on:
        - nextcloud-db

nginx.conf:

http {
    server {
        server_name url.com;
        location / {
            proxy_set_header X-Forwarded-Host $host;
            proxy_set_header X-Forwarded-Server $host;
            proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
            proxy_pass http://***.***.***.***:8070;
        }
        listen 443 ssl; # managed by Certbot
        ssl_certificate /etc/letsencrypt/live/url.com/fullchain.pem; # managed by Certbot
        ssl_certificate_key /etc/letsencrypt/live/url.com/privkey.pem; # managed by Certbot
        include /etc/letsencrypt/options-ssl-nginx.conf; # managed by Certbot
        ssl_dhparam /etc/letsencrypt/ssl-dhparams.pem; # managed by Certbot
    }
}

Viele GrĂŒĂŸe Meeett

Hallo Meeett,
ich hatte dasselbe Problem und habe auf diesem Blogpost die Lösung dargestellt:

https://techoverflow.net/2020/02/09/how-to-fix-onlyoffice-mixedcontent-or-refused-to-frame-http-because-it-violates-the-following-content-security-policy-directive-frame-src-https/

Kurz gesagt: In deine nginx-config muss

proxy_set_header X-Forwarded-Proto $scheme;

dann starte nginx neu und es sollte funktionieren.

Siehe auch mein Referenz-Setup:
https://techoverflow.net/2020/02/09/how-to-setup-onlyoffice-using-docker-compose-systemd-and-nginx/

Viele GrĂŒĂŸe, Uli Köhler