Docker NCP synology


I tried to switch from a VM with Debian Buster ant NCP (installed per curl) to a Docker on a Synology.
I will store the Dockerdata on a custom folder(volume1/nextcloud/) this folder is encrypted per Synology. The installation run without any Issue, but now I tried to restore the old backup I get the messange Can only restore from ext/btrfs filesystems. Now I’m wondering why my Nextcloudpi Panel also show data filesystem=ecryptfs.

Just from the error message and your description of your setup it seems likely that your debian installation was not using the btrfs filesystem making it unreadable by the synology filesystem (since it’s expecting btrfs). I could be way off, just a hunch.

no the docker run in a encrypted shared folder as docker on the synology. On the debian the partition also was a btrfs filesystem.

On the synology there is a volume (Raid 1) there runs the nextcloudpi docker. For my security I encryted the shared folder.

looks like I was way off… Sorry :woozy_face:

Here’s another thought… You mentioned that you encrypted the data folder via Synology.

this folder is encrypted per Synology.

ecryptfs is the encrypted file system Synology uses. It appears that the encryption is causing your issue. Perhaps docker doesn’t have permissions? Why not use Nextcloud’s encryption mechanism?

I will restore my data per Linux if Nextcloud crashs.

Now it’s running on the docker, I’m only fight with the restoring the files with the NCP restore script.