# Docker NC21 collabora issue

**URL:** <https://help.nextcloud.com/t/docker-nc21-collabora-issue/119404>\
**Category:** 📄 Office\
**Tags:** nc21, collabora-online\
**Created:** [July 2, 2021, 8:23am UTC](https://help.nextcloud.com/t/docker-nc21-collabora-issue/119404 "2021-07-02T08:23:44Z")\
**Posts on this page:** 1\
**Showing post:** 3

<div class="post-metadata">

**Author:** ![wwe](https://help.nextcloud.com/user_avatar/help.nextcloud.com/wwe/32/72963_2.png) [@wwe](https://help.nextcloud.com/u/wwe)\
**Post date:** [August 20, 2021, 8:09pm UTC](https://help.nextcloud.com/t/docker-nc21-collabora-issue/119404/3 "2021-08-20T20:09:58Z")

</div>

Hi all, finally collabora folks resolved the problem. Many thanks!!

After update to [collabora/code:6.4.10.10](https://hub.docker.com/layers/collabora/code/6.4.10.10/images/sha256-12873c6ba355d704d9b60bad6d6c314dcb8d7c3fa9748a49759da6ac94cfa206?context=explore) documents load again!!

It looks the problem was here

> <https://github.com/CollaboraOnline/online/issues/2752>
>
> \*\*Describe the bug\*\*
> With the latest update to Loolwsd 6.4.10 (and other collab…ora updates related), the server can't work anymore on a client which used the "SSLStrictSNIVHostCheck" setting to ON.
> This setup was working prior the latest updates.
> 
> \*\*To Reproduce\*\*
> Steps to reproduce the behavior:
> 1. On the client (hosting the NextCloud application for example), just set the "SSLStrictSNIVHostCheck" to ON
> 2. Try to open a document which Collabora would open, it will fail with an access denied.
> 3. Set the previous setting to off, test again, and it'll pass.
> 
> \*\*Expected behavior\*\*
> Should work.
> 
> \*\*Actual behavior\*\*
> Document can't load as the loolwsd service didn't comply with this Apache directive "SSLStrictSNIVHostCheck".
> 
> \*\*Desktop (please complete the following information)\*\*
> - OS: Debian 9.13
> - CODE : 
> \`\`\`
> # loolwsd --version-hash
> 51b8716
> \# loolwsd --version
> terminate called after throwing an instance of 'std::runtime\_error'
> Abandon
> \`\`\`
> \*\*As you may see, even the "--version" is broken there\*\*
> But in the log, we have this : 
> \`wsd-20943-20943 2021-07-04 15:30:34.621808 \[loolwsd \] INF Loolwsd version details: 6.4.10 - 51b8716 - on "Debian GNU/Linux 9 (stretch)"| wsd/LOOLWSD.cpp:4069\`
> 
> \*\*Additional context\*\*
> On the webserver : 
> Error.log
> \`\[Sun Jul 04 17:04:41.466646 2021\] \[ssl:error\] \[pid:tid\] AH02033: No hostname was provided via SNI for a name based virtual host\`
> 
> Access.log
> \`\`\`
> CODE SERVER IP - - \[04/Jul/2021:17:04:39 +0200\] "GET /index.php/apps/richdocuments/wopi/files/32\_odfl?access\_token=WXYZ&access\_token\_ttl=0 HTTP/1.1" 403 2255 "-" "LOOLWSD HTTP Agent 6.4.10"
> CODE SERVER IP - - \[04/Jul/2021:17:04:41 +0200\] "GET /index.php/apps/richdocuments/wopi/files/32\_odfl?access\_token=WXYZ&access\_token\_ttl=0&permission=edit HTTP/1.1" 403 2255 "-" "LOOLWSD HTTP Agent 6.4.10"
> \`\`\`
> 
> 
> On CODE server log : 
> \`wsd-00546-18244 2021-07-04 14:24:23.325579 \[docbroker\_010 \] ERR Failed to add session to \[/index.php/apps/richdocuments/wopi/files/32\_odfl\] with URI \[https://TLD/index.php/apps/richdocuments/wopi/files/32\_odfl?access\_token=WXYZ&access\_token\_ttl=0&permission=edit\]: WOPI::CheckFileInfo failed: \<!DOCTYPE html\>\`
> 
> 
> The SNI setting is enforced like this since a few months now, and was working at least 3 weeks back, so something might got broken in the recent update, hope you have all the needed infos.
> 
> 
> 
> 
> Edit : This issue happen only on a multiple domains server (several virtual hosts).
> I just did a test : 
> 
> NextCloud Virtual Host : SSLStrictSNIVHostCheck On
> OwnCloud Virtual Host : SSLStrictSNIVHostCheck Off
> 
> This setup is working and both can use the same CODE server.
> As soon as I put the "OwnCloud" to On, both fail.
> 
> Previously, this was a global variable, for the whole server, and this was working (so both to "On").
> CODE updated to 6-4-10.2 without change.

some references to collabora forum (multiple user report it works with 6.4.10.6):

[CODE 6.4.10\_Docker - Nextcloud (Not working)](https://forum.collaboraonline.com/t/code-6-4-10-docker-nextcloud-not-working/440)

[CODE connecting 0%: cannot connect to ods-document / stops working](https://forum.collaboraonline.com/t/code-connecting-0-cannot-connect-to-ods-document-stops-working/468)([https://forum.collaboraonline.com/t/code-connecting-0-cannot-connect-to-ods-document-stops-working/468](https://forum.collaboraonline.com/t/code-connecting-0-cannot-connect-to-ods-document-stops-working/468))

[CODE 6.4.10 - Well, this is embarrassing #2771](https://github.com/CollaboraOnline/online/issues/2771)

---

_[View the full topic](https://help.nextcloud.com/t/docker-nc21-collabora-issue/119404)._
