Docker installation works on local network but not from the internet (port mapping is correct)

When I run the following command, I can visit Nextcloud on my browser without issue and begin account creation (LAN):
docker run --name nextcloud -d -p 8080:80 nextcloud

But I want to expose it to the internet along with my other services, so I stop and delete this one, and do it again with the -e option:
docker run --name nextcloud -d -p 8080:80 nextcloud -e

Now Nextcloud isn’t available from my domain, but it also is not working on the LAN. I’ve tried adding the LAN IP as an argument for the trusted domains. My domain doesn’t have SSL (I don’t want it). Could that be the issue, or am I doing something else wrong with the -e option?

I don’t see anything wrong with -e… you definitely can provide multiple values.

But you definitely do something wrong if you connect your server without TLS with the internet. Modern browsers don’t like connections and we strongly advice you never ever offer any unencrypted services in the internet and please don’t ask for support in case you do.

Thanks. So the technical issue (which is what I want to learn) is that because my domain doesn’t have TLS, NextCloud is designed not to load?

In that case, if I use a domain that has TLS, will that resolve this issue? I was hoping not to include TLS until we are finished testing.

based on your description nobody can tell what is the reason of your problem as you didn’t post any config and logs. My assumption is you are doing something wrong trying to access the server locally different that externally but this is just a feeling… TLS is likely not related to it - but again don’t try to host Nextcloud without TLS on the internet.