DNS nextcloud not accessible

Hello,
I have configured my Ubuntu server with Snap to install nextcloud, I am having DNS problems, I have used cloudns.com to create my domain and point it to my server address, I have done everything I had to do which is to put URL in mine fritbox with the DNS and the mail I added my domain in the Config.php file but I can’t access this domain, what can I do?
Kindest regards Nicola Garatti.

Wouldn’t it be a good idea to explain IN DETAIL how your environment looks like, what you’ve tested from what devices using what application with which result and error messages etc.?! Please be as precise as possible otherwise it won’t be possible to provide an answer.

Hello,
Then I have a HP Prodesk 600 G1 spec: https://support.hp.com/us-en/product/hp-prodesk-600-g1-tower-pc/5387438/document/c03859136.
With Ubuntu Server 20.04.1 LTS installed on top, I installed via Snap Nextcloud, then I took the public IP address and ‘created’ the DNS with cloudns but when I try to access from any home computer it tells me that it is not is reachable.
Kindest regards Nicola Garatti.

What ip address is shown if you’re using the nslookup command on yoz fqdn?
Have you opened tcp ports for inbound connection to your server on your internet router?
Have you tested to access your server over the internet?
Are you sure that your internet router doesn’t block access to your public ip address on your LAN?

Hello!
Does your Nextcloud runs local on port 80/443? Did you open you Ports in the Fritzbox? (Is there a green light?) Did the Fritzbox reports Dyndns successfull login and shows you dyndns under Internet-> Online Monitor? grafik
Do you have a real IPv4 adress or DS-Lite?

Hi,
My fritz-box has activated the tcp 80/443 doors with the various green LEDs that indicate that it is active.
The DS-lite is not active (that of the ipv6 i mean), the DynDNS tells me that it is active and registered,
I found the public ip with the curl ifconfig.me/ip command
I tried to do the “ping mydomain” command and it tells me:
Reply from ‘IP’: Destination host not reachable.
Kind Regards Nicola Garatti.

So all tests still done from inside your lan which isn’t very helpful to analyze further. Have you configured dns rebind on the Fritzbox?

Hi,
In my router the Rebin DNS is set with my domain and even after restarting the router I still cannot access my domain.
Kindest regards Nicola Garatti.

Sorry, but all your replies are missing DETAILED INFORMATION, exact fqdn, ip addresses or precise command results etc., so that I won’t be able to give you any further advice.

Hello,
I apologize for the delay in answering but I had to study for some checks, FQDN of the local machine is:
home server
the external one I can’t access it
I got the external ip with the command:
curl ifconfig.me
(I did not put the public ip or the actual fqdn that will become his, forget if I have to put them, unfortunately I don’t know much in this field)
However, I also have a Synology NAS with an external DNS address already (already inside when I bought it) can it affect the fact that I cannot access the DNS?
Kindest regards Nicola Garatti

Hello,
Then I will explain everything in detail, I created a ‘new zone’ on Cloudns, in the ‘A’ section I did ‘Add new record’ and I entered the public ip address of the machine using the ‘curl ipconfig.me’ command I used on Ubuntu to locate the public address.
After that I used the two arrows to activate the DNS, I copied the DNS update link and went to my FritBox 7430 and went to Internet> Enablements> DynDNS I set these parameters:
DynDNS Provider: User defined;
Update URL: I put URL copied just now;
Domain name: I used the DNS I created;
Username: My Mail;
Password: my password;
After that I went to Internet> Sharing> Port sharing I selected the machine nextcloud is running on and I enabled ports 80 and 443 (HTTP and HTTPS).
Next I went to my machine and edited the ‘config.php’ file and put it in trusted tomorrow:
0 => ‘Mydns’,
I rebooted the machine using ‘sudo snap disable nextcloud’ and then ‘sudo snap enable nextcloud’,
In the end I tried to ping the domain to see if it was actually active and in fact it was I also checked on Cloudns and it actually is, the point is that if I try to access my domain it tells me:
Unable to reach the site
Mydns took too long to respond.

What can I do?
OS information: Ubuntu server 20.04
Nextcloud 20.0.1 installed using SNAP

  • Ok, so you tried to ping your server over the internet, right?
  • Have you double-checked that the resolved ip address is identical to the one which has been assigned to your router?
  • What ip protocol are you using on your lan and what is being used by your testing device on the internet?
  • Do you own a full DSL/VDSL internet link or e.g. a DSL light one? This mainly depends on the provider
  • Have you enabled remote access to your Fritzbox (which is usually been done over port 443/tcp too)?

Hello,

  1. So I tried to do the command ‘ping Mydns’ and it tells me:
    “Response from IP_del_router: Destination host not reachable”
  2. The IP of the machine where nextcloud runs is different from that of the router, I tested this thing by doing ‘curl ipconfig.me’ on the Ubuntu machine and output a certain IP while on my Fritbox I went to
    Internet> Online monitors> Online monitors and DNS servers used came out just what I tried to ping in the first step
  3. For my protocol I use a TCP for 80 and 443
  4. I don’t really know how to find the one you’re sorry about
  5. yes I have activated the 80/443
    However I noticed that if I go to ‘Diagnosis> Safety’ on my Fritbox it tells me:
    Internet connection
    Internet connected from 23.11.2020, at 19:00, Intred, IP address: of the router, now where I want to arrive, that the IP address I found in ‘Diagnosis> Security’ is different from the one described in point 1 by pinging the DNS and if I try to enter with that ip address found in the Diagnosis> Security section it takes me to a Nextcloud page of my server saying:

Log in via an untrusted domain
Contact your administrator. If you are an administrator, change the “trusted_domains” setting in config / config.php like the example available in config / config.sample.php.
More information on configuration can be found in the documentation.
Kind regrets Nicola Garatti.

Unfortunately that doesn’t answer my first question. From where are you trying to ping your router, over the internet or from your lan?

Ok. so your answer is that both addresses are identical, right?

Unfortunately that doesn’t answer my third question. I wanted to know if you’re trying to reach your server using IPv4 or IPv6?

Ok, please tell me which provider you’re using. This might help answering my question.

That sound good, because it shows that you’ve set-up everything in the right way, except the DynDNS setting in your Fritzbox configuration. So please fix that setting so that your DynDNS record is updated correctly.

Due to the fact that the ip address might change over the time, it won’t be a good idea to add the resolved external ip address to your trusted_domain setting in Nextcloud, which is required to get access to your server.

Hello,

  1. So I’m trying to ping my DNS from my LAN and not from the internet
  2. Yes, the address that comes out to me when I try to ping my DNS is the same as the DNS that comes out on the FritzBox
  3. I’m using the iPv4 protocols, I don’t even have iPv6 active
  4. My provider is Intred
  5. For the configuration of the Dyndns I put:

The type of DNS provider (user defined)
My Update URL
my DNS created with Cloudns
Username: my Email and not my username
Password: My password

Kindest regards Nicola Garatti.

Ok, you’ve might have missed what I wrote. Here you find a description how DynDNS can be enabled on a FritzBox:

Here you find informtion about how to automatically update your DynDNS record on a CloudDNS server. Most likely the https url is right way to go:

Hello,
So I tried to change the username and password inside the DynDNS as you told me but it doesn’t change and it tells me it’s not accessible.
I repeat then I found the public ip of the Ubuntu machine through ‘curl ipconfig’ which gave me its public ip address, now if I go to my FritzBox 7430 and go to the Internet> Monitor Online section I
several IPs come out:

Internet, iPv4: connected from 29.11.2020, 11:19 h, Intred,
IP address: xx.xxx.xx.xx

DNS servers used: yy.yyy.yyy.yyy (currently used, for standard requests)
zz.zz.zz.zz

(I put x, y, z to show that they are different from each other)
At this point what I did, I used the command: ‘ping Mydns’ and it came out that there was no response from zz.zz.zz.zz.
I also have a second NAS at home a Synology DS216j I don’t know if that’s the “interference” but its DNS is the factory one provided by Synology.
I do not know what to do.
(You saw the message now because I didn’t directly reply to the message, sorry)
Kindest regards Nicola Garatti.

I didn’t told you you should change the user name and password but should make sure that the update script works as expected. As long as the Fritzbox cannot update your ClouDNS information automatically, a configuration will only be valid until your router gets a different external ip address assigned.

Due to the fact that I don’t know ClouDNS, you need to find out how the http call need to look like to update the ClouDNS record.

Sorry, but I’m totally confused by your x, y, z replacements. Without DNS and IP information it is impossible for me to assist you any further.

It is difficult to help you with this. You need to know how your network looks like and on which devices DHCP and DNS servers are running or how you have set-up your routing. If you want to run your own server on your LAN you should at least know these network basics.

Furthermore all these problems have absolutely nothing to do with the Nextcloud software itself, because it is a network and server related problem.

1 Like

Hello,
I apologize since I did not fully explain what I meant is that if I go to 192.168.1.1 (i.e. in my fritbox), 2 different DNS addresses appear to me and a public IP address (that of the modem), when I pin the DNS of the server comes out that in practice it is pinging one of the two DNS of the Fritbox.
Shouldn’t it ping the IP address?
Kindest regards Nicola Garatti

Unfortunately I don’t understand what you want to tell me. Your Fritzbox gets an external ip address assigned as soon as it connects to the internet. You have to make sure the your Fritzbox automatically updates your ClouDNS record so that an “nslookup <your-cloudns-domain>” resolves to the external ip address which has been assigned to your router. Only if this works, you can go ahead and run further tests.