Disk size decrease after installing running on VM

,

Nextcloud version: 20.0.3
Operating system and version: Ubuntu 20.04
Apache or nginx version (eg, Apache 2.4.25):
PHP version: 7.4.3

The issue you are facing:

Is this the first time you’ve seen this error? (Y/N): n

Steps to replicate it:
A month ago I build my NC on VM, with seperated disk for data, the disk was 50GB,
after installation I saw unlimited disk space, so I go to Setting->System to check the ncdata disk,
found my 50 GB and limit users to this.
Before a week, I lost 10GB. They just vanished !
All the users now see limit of 40.8GB, when I see in my disks, disk with 44.02 GB amount.

The output of your Nextcloud log in Admin > Logging:

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php
$CONFIG = array (
  'passwordsalt' => '$$$',
  'secret' => '$$$',
  'trusted_domains' =>
  array (
    0 => 'localhost',
    1 => 'ip',
    2 => 'domain,
    3 => 'other domain',
  ),
  'datadirectory' => '/mnt/ncdata',
  'dbtype' => 'pgsql',
  'version' => '20.0.3.2',
  'overwrite.cli.url' => 'https://domain/',
  'dbname' => 'db_name',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'dbuser',
  'dbpassword' => '$$$',
  'installed' => true,
  'instanceid' => '$$$',
  'upgrade.disable-web' => 'true',
  'log_type' => 'file',
  'logfile' => '/var/log/nextcloud/nextcloud.log',
  'loglevel' => '2',
  'log.condition' =>
  array (
    'apps' =>
    array (
      0 => 'admin_audit',
    ),
  ),
  'mail_smtpmode' => 'smtp',
  'remember_login_cookie_lifetime' => '2419200',
  'log_rotate_size' => '10485760',
  'trashbin_retention_obligation' => 'auto, 180',
  'versions_retention_obligation' => 'auto, 365',
  'simpleSignUpLink.shown' => false,
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'filelocking.enabled' => true,
  'memcache.distributed' => '\\OC\\Memcache\\Redis',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'redis' =>
  array (
    'host' => '/var/run/redis/redis-server.sock',
    'port' => 0,
    'timeout' => 0.5,
    'dbindex' => 0,
    'password' => '$$$',
  ),
  'logtimezone' => 'my/location',
  'htaccess.RewriteBase' => '/',
  'enable_previews' => true,
  'enabledPreviewProviders' =>
  array (
    0 => 'OC\\Preview\\PNG',
    1 => 'OC\\Preview\\JPEG',
    2 => 'OC\\Preview\\GIF',
    3 => 'OC\\Preview\\BMP',
    4 => 'OC\\Preview\\MarkDown',
    5 => 'OC\\Preview\\MP3',
    6 => 'OC\\Preview\\TXT',
    7 => 'OC\\Preview\\Movie',
    8 => 'OC\\Preview\\Photoshop',
    9 => 'OC\\Preview\\SVG',
    10 => 'OC\\Preview\\TIFF',
  ),
  'preview_max_x' => '2048',
  'preview_max_y' => '2048',
  'jpeg_quality' => '60',
  'maintenance' => false,
  'mail_from_address' => 'contact',
  'mail_sendmailmode' => 'smtp',
  'mail_domain' => 'domain',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtpsecure' => 'ssl',
  'mail_smtphost' => 'email-server',
  'mail_smtpport' => '465',
  'mail_smtpauth' => 1,
  'mail_smtpname' => '$$$',
  'mail_smtppassword' => '$$$',
  'updater.secret' => '$$$',
);

The output of your Apache/nginx/system log in /var/log/____: (not sure what file needed)

$ cat /var/log/apache2/
access.log                    other_vhosts_access.log
error.log                     other_vhosts_access.log.1
error.log.1                   other_vhosts_access.log.2.gz
error.log.2.gz                other_vhosts_access.log.3.gz
error.log.3.gz                other_vhosts_access.log.4.gz
error.log.4.gz                other_vhosts_access.log.5.gz
error.log.5.gz                other_vhosts_access.log.6.gz
error.log.6.gz                other_vhosts_access.log.7.gz
error.log.7.gz

In my ubuntu I see the disk is about 45GB