Disable passwordless login and remove "Log in with a device" link on login page

Hi,

With Nextcloud 19.0.0.12, is there a way to remove and disable the “Log in with a device” link on the login page? We do not use passwordless login and would also like to disable this capability.

I have looked in docs to see if there has been a new parameter added to config.php, but couldn’t find anything there: https://docs.nextcloud.com/server/latest/admin_manual/configuration_server/config_sample_php_parameters.html

Is there an undocumented option for config.php? Or some other setting somewhere? I couldn’t find any setting in /settings/admin, etc.

Thank you

1 Like

auth.webauthn.enabled is the config key.

1 Like

Thank you kindly for that!

I’d suggest better documentation though for those interested in that sort of feedback. The entry for auth.webauthn.enabled is very nondescript, and no wonder searches also return no matches!

Also FYI, I think as of right now, there’s an SSL error on https://docs.nextcloud.com/server/latest/admin_manual/configuration_server/config_sample_php_parameters.html. Seems like cert expired yesterday at 2am. Just so you know!

Thanks :slight_smile:

The SSL certificate was extended

Search for documentation:
deactivate webauthn nextcloud

In Germany first hit:

https://www.hostflash.de/blog/webhosting/webauthn-fido2-in-nextcloud-19-deaktivieren-anleitung.html

The Actual line in config.php will be
‘auth.webauthn.enabled’ => false,

1 Like

This is not working for me. I have

  'auth.webauthn.enabled' => 'false',

in my config.php but the “Log in with a device” link still shows on my login page.
I’m running the NC 22 apache docker image.

Hi @guystreeter

Remove the single quotes from the value ‘false’, then it should work. Like this…

'auth.webauthn.enabled' => false,
2 Likes