Disable "live" previews but display previews generated by cronjob

Is it possible to deactivate the on demand preview generation but display preview images that were generated in the background by a cron job?

I have the problem that the memory on my Raspi 4 with 8 GB RAM fills up when the on demand previews are generated. The setting
‘preview_concurrency_new’ => 1,
‘preview_concurrency_all’ => 2,
in config.php unfortunately did not bring any improvement.

As there is not a lot of documentation about theese parameters, i understood theese semaphore config to be used in generating live previews. So have you tried to set them to zero and run occ on the other hand ?
How many files do you have in a folder ? My Raspi has only 4GB, php is restricted to 2 GB and im encountering no Problems ?
Used/Cached Memory in Linux isnt really a Problem. You mean the memory isnt freed and the System is swapping ?

Regards

Thanks for your suggestion. I will try that.

I have about 1000 photos in one folder. I can see a lot apache2 processes spawning while previews are generated (a lot more then 2).

Unfortunately, however, the setting
‘preview_concurrency_new’ => 1,
‘preview_concurrency_all’ => 2,
does not seem to have been taken into account. If it were taken into account, I probably wouldn’t have a problem.