Directory sizes and usage number going wrong

Hi, new to the forum, thanks for the great tool and community! Now, I am facing a few issues related to larger directories (not individual files) and would greatly appreciate any help, tried understanding/fixing/narrowing this down but no success so far, couldn’t find any posts with exactly the same problem.

  1. The storage usage displayed in the lower left corner goes astray, e.g. showing 68GB even though I am using 11GB only. The command occ files:scan --all will bring this number back to the correct one, but only until I touch anything, at which point the number goes astray again (to the same, wrong number).
  2. some directories do not show their “last updated” and “size” property correctly, even though subfolders inside them do. Notably, this happens on a directory that is >2GB (again, individual files are way smaller than 2GB).

Thanks and cheers

Nextcloud version: 20.0.8
Operating system and version: Debian Buster (arm64 nextcloudpi)
Apache or nginx versionApache/2.4.38 (Debian)
PHP version PHP 7.3.27-1~deb10u1

1 Like

Hello @ave hope you are doing well…

First of all, welcome to our great community.

About your issue there, two things that I need to know for further help:

1) Do you use any cache service, like redis for example.
2) Are you using cron or ajax?
3) The notification of the new released NC 21.0.1 appeared on your application?
4) Are you running php-fpm?

With that info it will be easier to help.

Also, in the log files something strange appears or not?

Good luck mate.


Hi @Beltran1337 , thanks, hope you’re well too!

To answer your questions:

  1. yes, I use redis
  2. cron
  3. no, it does offer 20.0.9 though
  4. yes I run php-fpm

I don’t see anything in the log files that I could relate to this.

Does that improve my question?


Nice man, thank you for your time.

Now we can start debugging and fixing things :smiley:

First of all, did you read the changelog about the 20.0.9 version? Maybe they fixed this bug and we do not have to break our heads to discover it.

But I believe you already checked that, so next step is to see your /etc/php.ini and your /etc/opt/remi/php74/php-fpm.d/www.conf files. If they are in another directory please change it.

20.0.9 does not fix this issue for me.

I paste php.ini and www.conf here - nc conf

I made the workaround of copying all files inside a problematic folder that wouldn’t update its last-edit-timestamp into a new folder. The new folder seems to behave correctly so far. The total space usage counter still goes astray and I did not determine what the actual problem with the file property not getting updated was, so I would not call this a solution.