Different Theme output on two Nextcloud 11 instances

Hey guys,

out of curiosity I have a question. I have a couple of own-/Nextcloud instances running for testing different versions and settings. At the moment I have two different Nextcloud 11 instances running and they behave different when I use the Theming App.

Instance 1: Nextcloud 11 running on a public server (Ubuntu, Apache), coming from ownCloud 8. Only using the Theming app, no separate theme folder.
Everything works great, own icon, names, color, etc. even the favicon changes depending on my set color and icon.

Instance 2: Nexcloud 11 VM , clean Nextcloud 10 installation from https://www.techandme.se in Virtualbox, updated to version 11 using the shipped updater script. Only using the Theming app, no separate theme folder.
Every theming option works fine, except the favicon. No matter what I set in the options, it stays the standard blue Nextcloud icon.

Can anyone tell me how that can be? Am I missing something?

What I figured is, that the source code output of the two instances is different aswell.

Source of instance 1: (the working one)

<meta name="theme-color" content="#2A4B70">
<link rel="icon" href="/index.php/apps/theming/favicon/files?v=46">
<link rel="apple-touch-icon-precomposed" href="/index.php/apps/theming/icon/files?v=46">
<link rel="mask-icon" sizes="any" href="/core/img/favicon-mask.svg" color="#0082c9">

Source of instance 2: (the one where the favicon stays standard)

<meta name="theme-color" content="#505050">
<link rel="icon" href="/core/img/favicon.ico">
<link rel="apple-touch-icon-precomposed" href="/core/img/favicon-touch.png">
<link rel="mask-icon" sizes="any" href="/core/img/favicon-mask.svg" color="#0082c9">

I already reset all options in the theming App of my second Nextcloud instance. I also deactivated and reactivated the App with no change in functionality.

Any ideas? I just don’t get it…

Thanks in advance.

Cheers yiria