''deutsch'' -> Nextcloud 21| client push, installations findet redis server nicht

Hallo liebe Community,

Ich will bei meiner Nextcloud den Client push zum laufen bekommen, nur bekomme ich bei der eingabe von

‘occ notify_push:setup’ im OCC nur ein Objekt ausgabe.

wenn ich direkt nach Anleitung gehe komme ich zu dem punkt wo ich ins Nextcloud Verzeichnis soll um dort folgenden Befehl auszugeben ‘sudo -u www-data php occ notify_push:setup’ jedoch bekomme ich die Meldung ‘‘redis is required’’ und die einrihctung geht nicht weiter,

Redis ist errichbar wenn ich redis-cli in sterminal eingebe. also läuft der redis-server

habt ihr villleicht eine Ahnung oder sogar die lösung!?! ich Würde mich freunen

LG

Techiesgeek

Richte Redis als Memory Cache ein, wie es im Nextcloud Administrator Guide beschrieben wird:

Memory caching — Nextcloud latest Administration Manual latest documentation

Dies ist bereist schon wären der Installation der Nextcloud mit redis erledigt worden,

mit der Anleitung habe ich das gemacht, ich habe alle config’s nachgeschaut und es ist alles vorhanden Redis ist als Memcache eingerichtet jedoch bekomme ich immer noch diese Fehlermeldung beim ausführen des Befehls!

Wie sehen denn die in der config.php gesetzten Redis-Parameter im Detail aus?

Da es einen Unterschied macht, ob ich das PHP Web oder CLI-Interface für die Abfrage benutze, solltest Du schauen, ob das Redis-Modul auch korrekt für die CLI-Komponente geladen wird: php -m | grep redis

This information might help getting the app up-and-running:

so sehen die einträge in der Config.php aus:

‘memcache.local’ => ‘\OC\Memcache\APCu’,
‘memcache.locking’ => ‘\OC\Memcache\Redis’,
‘preview_max_x’ => 1024,
‘preview_max_y’ => 768,
‘preview_max_scale_factor’ => 1,
‘redis’ =>
array (
‘host’ => ‘/var/run/redis/redis-server.sock’,
‘port’ => 0,

Bei der php abfrage bekomme ich keine ausgabe, es wird einfach eine zeile nach unten versetz.

Ah noch zur Info mit der Anleitung habe habe ich meine Ubuntu Server aufgesetzt: Nextcloud 21 Installationsanleitung v. 2.2 – Carsten Rieger IT-Services.

Dort wird auch beschrieben wie es mit dem client push gemacht wird aber leider geht es halt nicht. habe alles so gemacht wie in der Anleitung,( natürlich die Parameter angepasst damit die Cloud auch funktioniert.

Ich fahre das ganze zu Tests zwecken derzeit auf eine Intel i5 mit 8 GB ram, System auf SSD und daten auf HDD.

daher kann ich grade nichts mit dem Docker anfangen. da ich nativ mit ubuntu arbeiten tu, direkt per CMD oder powerhell.

Die Konfiguration sieht meines Erachtens soweit korrekt aus. Wenn der genannte php-Befehl (php -m) kein redis-Modul aufführt, dann wird das Modul für die PHP-CLI-Komponente wohl nicht geladen, was durchaus die Fehlerursache sein könnte.

nach Ausführung der php -m kam raus das redis nicht in der Modul liste steht, wie kann ich redis denn jetzt in php laden??

Und danke bis jetzt für deine Hilfe.

Mittels php -i kannst Du Dir die PHP CLI-Konfiguration anzeigen lassen an dessen Anfang u.a. der Pfad zur Konfigurationsdatei oder auch zu zusätzlichen ini-Datei angezeigt wird, welche standardmäßig geladen werden.

D.h. vermutlich gibt es auf Deinem Server ein Verzeichnis /etc/php/7.x/... o.ä. aus welchem die Konfigurationsdateien gelesen werden. Dort musst Du sicher stellen, dass eine Datei redis.ini existiert die mindestens den Eintrag “extension=redis.so” enthält.

Siehe auch:

https://www.xprog.de/topics/install-php-on-ubuntu/

also meine .ini’s liegen in ‘’/etc/php/7.4/cli/conf.d’’ Ordner, ich habe dann natürlich eine redis.ini angelegt und deinen Schnipsel dort eingetragen. die PHP 7.4 scheint aber auch Probleme mit Redis zu haben. dennoch habe ich jetzt seit gestern kein Workaround gefunden.

ich glaube ich sollte den test server nochmal schritt für schritt neu aufsetzten, denn es kann ja nicht sein das egal was ich da versuche nicht klappt. Redis ist eingerichtet aAPU oder wie sich das schimpft ist auch kommplett eingerichtet und dennoch geht es nicht, das kann ja nicht wirklich sein, ich bin jetzt das komplette php wiki und ubuntu durch, habe deine Tipps befolgt, aber weiter komm ich nicht, da scheint mein wissen mit php noch recht klein zu sein.