Desktop client invisible in KDE

Using Arch with KDE, the taskbar icon will open and display a blank drop down status window. Clicking in random places will open links as if the content is visible but it is not. In a dark theme, the menu is black with no content. In a light theme the menu is light with no content. Other KDE taskbar applications render properly and this is unique to Nextcloud.

I have reinstalled the client, tried deleting ~/.cache/Nextcloud and ~/.config/Nextcloud, tried and changing KDE themes. I’ve tried rebooting many time and the problem has persisted for over a month.

Does anyone know how to fix this or what is causing it?

I’d start with the logs:

there is a command to start with a logging window (that probably won’t help you at this point), but further down there is an option to start from commandline and log into a file.

Thanks for the suggestion. The client just produced 2.1 GB of logs. Any ideas of what I should be looking for?

Just start the client until you see the problem and just check the lines that have been added since you started the client. If there is still too much, you can search for “error”, “problem”, “missing”, “timeout”, … and such keywords.
I don’t know how you installed the client on Linux and if you need to fullfill certain dependencies for the GUI…

Installed with sudo pacman -Syu nextcloud-desktop which should automatically satisfy dependencies. Using nvidia graphics, and KDE with x11 base.

The only keyword I found in the log was timeout here, but this is likely unrelated.

2022-12-28 06:57:26:846 [ info nextcloud.gui.folder.manager /build/nextcloud-client/src/nextcloud-client/src/gui/folderman.cpp:896 ]:	Etag poll timer timeout
2022-12-28 06:57:26:846 [ info nextcloud.gui.folder.manager /build/nextcloud-client/src/nextcloud-client/src/gui/folderman.cpp:900 ]:	Folders to sync: 1
2022-12-28 06:57:26:847 [ info nextcloud.gui.folder.manager /build/nextcloud-client/src/nextcloud-client/src/gui/folderman.cpp:910 ]:	Number of folders that don't use push notifications: 1
2022-12-28 06:57:26:847 [ info nextcloud.gui.folder.manager /build/nextcloud-client/src/nextcloud-client/src/gui/folderman.cpp:927 ]:	Run etag job on folder OCC::Folder(0x560e4cb14400)
2022-12-28 06:57:26:847 [ info nextcloud.gui.folder.manager /build/nextcloud-client/src/nextcloud-client/src/gui/folderman.cpp:951 ]:	Can not run etag job: Polltime not reached
2022-12-28 06:57:27:156 [ info nextcloud.sync.credentials.webflow /build/nextcloud-client/src/nextcloud-client/src/gui/creds/webflowcredentials.cpp:426 ]:	request finished

My guess is that this is caused by an unrelated issues where I am having trouble with a folder that isn’t getting deleted from the server automatically.

Here they have some commands to check for dependencies:

So does it sync stuff from the server? If that is some problem with deleting from the server, there should then be some error messages in the webserver log (4xx error for permission problems).

Is that your problem? They have a workaround for that:

Thanks for the suggestion. Looks like this bug is in Wayland and I am using X11