Desktop client has persistent "Connection Closed" messages

Well I enabled debug messages in the client log. And the key line I see is:

[OCC::AbstractNetworkJob::slotFinished 	QNetworkReply::RemoteHostClosedError "Connection closed" QVariant(Invalid)

That is the server response to:

[OCC::AbstractNetworkJob::start 	OCC::PUTFileJob created for "https://nephele.lan" + "/6 Montagu/House Management/Projects/Bike Shed/Plan.dxf~" "OCC::PropagateUploadFileV1"
[OCC::WebFlowCredentials::slotFinished 	request finished

The clue is: QNetworkReply::RemoteHostClosedError "Connection closed" QVariant(Invalid)

But not much of a clue. What does that mean?

I’m running in to the same issue on macOS, tested both 3.0.0 and 2.6.5 clients. I installed the Notes app in Nextcloud and when the desktop client tries to sync the Notes folder, with only one note in it, it fails with “connection closed”.

My log has:

2020-08-21 16:41:12:631 [ warning nextcloud.sync.networkjob ]:	QNetworkReply::RemoteHostClosedError "Connection closed" QVariant(int, 200)
2020-08-21 16:41:12:632 [ warning nextcloud.sync.credentials.webflow ]:	QNetworkReply::RemoteHostClosedError
2020-08-21 16:41:12:632 [ warning nextcloud.sync.credentials.webflow ]:	"Connection closed"
1 Like

Same here

OS: Linux Mint 20
Nextcloud-client Version: 3 and 2.6.5

Nextcloud 19 on ODroid via NextcloudPI

2020-09-01 18:31:59:921 [ warning nextcloud.gui.activity ]:	Item  "LINK OF FILE"  retrieved resulted in  "Verbindung beendet"
2020-09-01 18:31:59:922 [ warning nextcloud.gui.activity ]:	Item  "LINK OF FILE"  retrieved resulted in error  "Verbindung beendet"
2020-09-01 18:31:59:923 [ info nextcloud.gui.activity ]:	Error successfully added to the notification list:  "Verbindung beendet"
2020-09-01 18:32:00:013 [ info nextcloud.sync.credentials.webflow ]:	request finished
2020-09-01 18:32:00:014 [ warning nextcloud.sync.networkjob ]:	QNetworkReply::RemoteHostClosedError "Verbindung beendet" QVariant(Invalid)
2020-09-01 18:32:00:014 [ warning nextcloud.sync.credentials.webflow ]:	QNetworkReply::RemoteHostClosedError
2020-09-01 18:32:00:014 [ warning nextcloud.sync.credentials.webflow ]:	"Verbindung beendet"
2020-09-01 18:32:00:014 [ info nextcloud.sync.networkjob.put ]:	PUT of "https://IP/remote.php/dav/uploads/USER/3276602578/00000000" FINISHED WITH STATUS "RemoteHostClosedError Verbindung beendet" QVariant(Invalid) QVariant(Invalid)
2020-09-01 18:32:00:015 [ warning nextcloud.sync.propagator ]:	Could not complete propagation of "LINK OF FILE" by OCC::PropagateUploadFileNG(0x561dd2cc4170) with status 2 and error: "Verbindung beendet"
2020-09-01 18:32:00:016 [ warning nextcloud.gui.activity ]:	Item  "LINK OF FILE"  retrieved resulted in  "Verbindung beendet"
2020-09-01 18:32:00:017 [ warning nextcloud.gui.activity ]:	Item  "LINK OF FILE"  retrieved resulted in error  "Verbindung beendet"
2020-09-01 18:32:00:017 [ info nextcloud.gui.activity ]:	Error successfully added to the notification list:  "Verbindung beendet"
2020-09-01 18:32:00:136 [ info nextcloud.sync.database ]:	Closing DB "/home/USER/.local/share/Nextcloud/._sync_6ce549485806.db"

(Verbindung beendet means connection closed)

This config works absolutly fine the last year till today. The Log is from Nextcloud-Client (I tried both versions)
I also can’t upload files via Browser:

Expected filesize of 1200718 bytes but read (from Nextcloud client) and wrote (to Nextcloud storage) 8192 bytes. Could either be a network problem on the sending side or a problem writing to the storage on the server side.

Additional Information:

The update to NC19 was today (autoupdate from NCP)

I have the same problem on my Mac, after updating to Nextcloud 20. I don’t remember if it came with 20.0.0 or 20.0.1. I tried to fix it by enabling php fpm (Apache) in the php settings but it didn’t help. Any ideas?

I am having the exact same problem with my installation on 4 large .pdf files. Is there a solution or workaround?

Same problem here on NC 20.0.8 + Linux Desktop Client (2.6.5). PHP-FPM up and running. This bug seems to be very nasty and it is making almost impossible to synchronize large pdf and odt (LibreOffice writer) files.

Having the same issue with NextCloud 21.0.1 and Mac Desktop Client 3.1.3. The file with the issue is a 20MB PDF.

Same issue. Nextcloud docker fpm image 21.0.1, Mac client 3.2.0. Large files upload succeeded but failed to sync back on another mac.

Same issue after updating from 20.0.7 to 20.0.8 . Windows 10 client : 3.1.3.
Big size files are not the only one concerned in my case. This seems to be random. File transfert speed seems slower than before, after multiple attemps, i manage to synchronise all my directories one after another by checking one more box after a successfull synchronization

same issue with windows client.
not sure what todo next.

php Version: 8.0.3
Memory Limit: 2 GB
Max Execution Time: 3600
Upload max size: 10 GB
Type: mysql
Version: 10.5.9
Size: 70.8 MB

Same here. Nextcloud/Owncloud has the worst sync client. When there’s a lot of new file to sync, I have to babysit it as it keeps failing and I have to force resync multiple times. Frustrating.

Same here. Frustrating.

Lots of ppl with this problem, no solutions, no fixes, Nextcloud is not suitable for busyness environment in my opinion. Probably not even for home, I have been giving it a try for some months but I ran into so many problems. If you are not English-speaking lang it’s even worst.

Same here, I’m not able to sync a bunch of PSD files bigger than 100mb. The only error is “Connection closed” and my dog doesn’t stop farting , I’m going crazy

Hello, I came to the forum for help on the Connection Closed messages too. I am using the NC client version 3.4.1 on Linux, and I am getting these messages too for larger files.

2022-01-08 23:24:24:532 [ info nextcloud.sync.networkjob /home/user/src/libsync/abstractnetworkjob.cpp:361 ]: OCC::PUTFileJob created for “https://nextcloud.example” + “” “OCC::PropagateUploadFileNG”
2022-01-08 23:24:24:532 [ debug nextcloud.sync.networkjob /home/user/src/libsync/abstractnetworkjob.cpp:298 ] [ OCC::AbstractNetworkJob::slotFinished ]: Network job OCC::PUTFileJob finished for “”
2022-01-08 23:24:25:100 [ info nextcloud.sync.credentials.webflow /home/user/src/gui/creds/webflowcredentials.cpp:425 ]: request finished
2022-01-08 23:24:25:100 [ warning nextcloud.sync.networkjob /home/user/src/libsync/abstractnetworkjob.cpp:224 ]: QNetworkReply::RemoteHostClosedError “Connection closed” QVariant(Invalid)
2022-01-08 23:24:25:100 [ warning nextcloud.sync.credentials.webflow /home/user/src/gui/creds/webflowcredentials.cpp:227 ]: QNetworkReply::RemoteHostClosedError
2022-01-08 23:24:25:100 [ warning nextcloud.sync.credentials.webflow /home/user/src/gui/creds/webflowcredentials.cpp:228 ]: “Connection closed”
2022-01-08 23:24:25:100 [ info nextcloud.sync.networkjob.put /home/user/src/libsync/propagateupload.cpp:87 ]: PUT of “https://nextcloud.example/remote.php/dav/uploads/exampleuser/1216977380/0000000000000048” FINISHED WITH STATUS “RemoteHostClosedError Connection closed” QVariant(Invalid) QVariant(Invalid)

I checked on the server side too, but couldn’t find anything that seemed to relate to the Connection Closed issues there.


We are having the same problem. The server log is completely silent.
Is this maybe in combination with the group-folder extension?

Maybe it will help someone.

But my problem with “Connection Closed” messages from the Nextcloud sync client (windows app) was caused by the maximum limit set by the Nextcloud admin. When I logged into Nextcloud from the webbrowser I got a notification “Your storage is full, files can not be updated or synced anymore!”. So if you have this issue, you can check if you’re on the limit for your cloud.

This problem has been annoying me for quite a while.

I think I’m going to switch away from Nextcloud given how often it happens. There are better options out there that work better.

this doesn’t just happen with the desktop client. i’m also unable to add the files directly via the browser. other files work, just the large .pdfs have this issue. is there any workaround?

have also tried adding them to an archive first, but the same issue happens.