Desktop Client 3.2RC1 ready, help test!

The Nextcloud desktop team just made RC1 of the new major version available! This release comes with a lot of changes to the sync engine, many UI fixes, improvements to end-to-end encryption, a virtual file system, a new installation wizard and more. So, it needs some real testing!

You can find a list of the main included commits on github, where you can also download the builds for mac :apple: , linux :penguin: and windows :wine_glass:

We’d like to ask for help with testing these in particular:

  • if you had regular sync issues, try this RC and tell us if they are resolved or not!
  • if you had problems with the conflict handling dialog, they should be fixed. Let us know!
  • If you tried end-to-end encryptions and experienced problems, they should be resolved - let us know!
  • try the virtual file system, especially on Windows
  • we’d love to hear what you think of the new installation wizard!

You can put your :heart: below, and ask questions, but real bug reports are best filed on github (be sure to check for duplicates please)!


I tried to create the Linux build, did the git clone step and tried to install, but run into errors.

CMake Error at /usr/lib/x86_64-linux-gnu/cmake/Qt5/Qt5Config.cmake:28 (find_package):
Could not find a package configuration file provided by “Qt5QuickControls2”
with any of the following names:


Package libqt5quickcontrols2-5 is installed. There seem to be missing some packages on the dependancy list.

Does this release run natively on Apple ARM machines? The NextCloud Desktop Client is the last remaining app I use which is still running in emulation mode.


Ok, I found the AppImage. That works so far.

My server runs on NC 20.0.8. When the client is started, it issues a warning:
The server version is unsupported. Proceed at your own risk.

I am reverting to client 3.1.3 for now.

Please see issues at Issues · nextcloud/desktop · GitHub

Any news about Next loud client for raspberry?
I compiled an old version and I’m using it to mirror the server to a secondary one for safety

Please open a new topic or even better check github for existing issues.

Link :

1 Like

Installs just fine on Manjaro ARM via standard package manager. Has been working fine for as long as I can remember release wise.