Deleted Nextcloud.log / files not loading - sometimes

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 12.0.2): 16
Operating system and version (eg, Ubuntu 17.04): Debian 9
Apache or nginx version (eg, Apache 2.4.25): Apache/2.4.25
PHP version (eg, 7.1): PHP 7.2.18

The issue you are facing:
I deleted my nextcloud.log to have a clean log in my Nextcloud.
Now i can’t access my files anymore.
Redis is encountering errors.

Is this the first time you’ve seen this error? (Y/N):
Y
Steps to replicate it:

  1. Delete Nextcloud.log

The output of your Nextcloud log in Admin > Logging:

Nothing deleted it <.<

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php $CONFIG = array ( 'instanceid' => '****', 'passwordsalt' => '****', 'secret' => '****', 'trusted_domains' => array ( 0 => '****', 1 => '****.de', 2 => 'www.****.de', 3 => 'cloud.****.de', ), 'datadirectory' => '/var/nextcloud/data', 'dbtype' => 'mysql', 'version' => '16.0.0.9', 'csrf.disabled' => true, 'overwrite.cli.url' => 'https://****.de/nextcloud', 'dbname' => '****', 'dbhost' => '****', 'dbport' => '****', 'dbtableprefix' => 'oc_', 'dbuser' => '****', 'dbpassword' => '****', 'installed' => true, 'maintenance' => false, 'theme' => '', 'loglevel' => 2, 'memcache.local' => '\\OC\\Memcache\\Redis', 'redis' => array ( 'host' => 'localhost', 'port' => 6379, ), 'memcache.locking' => '\\OC\\Memcache\\Redis', 'cache_path' => '/var/nextcloud/data/usercache', 'mail_domain' => '****.de', 'mail_from_address' => 'info', 'mail_smtpmode' => 'smtp', 'mail_sendmailmode' => 'smtp', 'mail_smtpauth' => 1, 'mail_smtpport' => '25', 'mail_smtphost' => '127.0.0.1', 'mail_smtpname' => '****', 'mail_smtppassword' => '****', 'mail_smtpauthtype' => 'PLAIN', 'mysql.utf8mb4' => true, 'ldapIgnoreNamingRules' => false, 'ldapProviderFactory' => 'OCA\\User_LDAP\\LDAPProviderFactory', 'app_install_overwrite' => array ( 0 => 'mail', 1 => 'passman', 2 => 'end_to_end_encryption', 3 => 'radio', ), 'data-fingerprint' => '****', );

RedisException: Redis server went away

  1. /var/www/html/foundation/nextcloud/lib/private/Memcache/Redis.php - line 54:Redis->get(“27b57003480 … 8”)
  2. /var/www/html/foundation/nextcloud/lib/private/App/InfoParser.php - line 57:OC\Memcache\Redis->get("/var/www/ht … 8")
  3. /var/www/html/foundation/nextcloud/lib/private/App/AppManager.php - line 381:OC\App\InfoParser->parse("/var/www/ht … l")
  4. /var/www/html/foundation/nextcloud/lib/private/legacy/app.php - line 551:OC\App\AppManager->getAppInfo(“files”, false, null)
  5. /var/www/html/foundation/nextcloud/lib/private/AppFramework/App.php - line 66:OC_App::getAppInfo(“files”)
  6. /var/www/html/foundation/nextcloud/lib/private/legacy/app.php - line 236:OC\AppFramework\App::buildAppNamespace(“files”)
  7. /var/www/html/foundation/nextcloud/lib/private/legacy/app.php - line 119:OC_App::registerAutoloading(“files”, “/var/www/ht … s”)
  8. /var/www/html/foundation/nextcloud/lib/base.php - line 640:OC_App::loadApps([ “session”])
  9. /var/www/html/foundation/nextcloud/lib/base.php - line 1056:OC::init()
  10. /var/www/html/foundation/nextcloud/remote.php - line 111:require_once("/var/www/ht … p")

The Redis server is used for file locking, therefore this could be an explanation for the described problem. Make sure that the Redis server is up-and-running to prevent such a problem in the future.

My Redis Server is running and it worked before i deleted the nextcloud.log, i switched to apcu now and everything is working again…

The existence of the Nextcloud log file has definitely no influence on the function of the Redis server. To be honest, I would assume that you’ve changed something else which has caused a Redis server problem.

1 Like

fixed by adding redis:x:113:www-data to my /etc/group

If someone is interested, here is my new working config.php using APCu and Redis in combination:

<?php

$CONFIG = array (
‘instanceid’ => ‘’,
‘passwordsalt’ => '
’,
‘secret’ => ‘’,
‘trusted_domains’ =>
array (
0 => '
’,
1 => ‘.de’,
2 => 'www.
.de’,
3 => ‘cloud..de’,
),
‘datadirectory’ => ‘/var/nextcloud/data’,
‘dbtype’ => ‘mysql’,
‘version’ => ‘16.0.0.9’,
‘csrf.disabled’ => true,
‘overwrite.cli.url’ => 'https://
.de/nextcloud’,
‘dbname’ => ‘nextclouddb’,
‘dbhost’ => ‘localhost’,
‘dbport’ => ‘3306’,
‘dbtableprefix’ => ‘oc_’,
‘dbuser’ => ‘’,
‘dbpassword’ => '
’,
‘installed’ => true,
‘maintenance’ => false,
‘theme’ => ‘’,
‘loglevel’ => 3,
‘logfile’ => ‘/var/nextcloud/data/nextcloud.log’,
‘memcache.local’ => ‘\OC\Memcache\APCu’,
‘memcache.distributed’ => ‘\OC\Memcache\Redis’,
‘redis’ =>
array (
‘host’ => ‘/var/run/redis/redis.sock’,
‘port’ => 0,
‘dbindex’ => 0,
‘password’ => ‘’,
‘timeout’ => 1.5,
),
‘cache_path’ => ‘/var/nextcloud/data/usercache’,
‘mail_domain’ => '
.de’,
‘mail_from_address’ => ‘info’,
‘mail_smtpmode’ => ‘smtp’,
‘mail_sendmailmode’ => ‘smtp’,
‘mail_smtpauth’ => 1,
‘mail_smtpport’ => ‘25’,
‘mail_smtphost’ => ‘127.0.0.1’,
‘mail_smtpname’ => ‘’,
‘mail_smtppassword’ => '
’,
‘mail_smtpauthtype’ => ‘PLAIN’,
‘mysql.utf8mb4’ => true,
‘ldapIgnoreNamingRules’ => false,
‘ldapProviderFactory’ => ‘OCA\User_LDAP\LDAPProviderFactory’,
‘app_install_overwrite’ =>
array (
0 => ‘mail’,
1 => ‘passman’,
2 => ‘end_to_end_encryption’,
3 => ‘radio’,
),
‘data-fingerprint’ => ‘*’,
);