Default index page with Nginx

Installed using the Web Installer on a VPS. Installation whent fine (web installer said so).
Now it just shows the default nginx index page.
I followed this guide and looked around a LOT for a solution but no luck. My nginx config is identical to the one linked above (except for root, ssl, and that sort of stuff).
Most I can find is open() "/usr/share/nginx/html/favicon.ico" failed on nginx error.log.
Messed around with my php settings as well but no luck.

favicon.ico,This is just a website icon,You don’t need to pay attention to him,The root directory of the configuration file is:root /var/www/nextcloud,You need to unzip the nextcloud package into this directory and set the user and group to nginx。

Then you need to configure fastcgi correctly, check whether php-fpm uses TCP connection or sock connection

upstream php-handler {
    server unix:/var/run/php74-fpm.sock;


[root@Example ~]# cat `find / -name www.conf` | grep '^listen'
listen = /var/run/php74-fpm.sock
listen.owner = nginx = nginx
listen.mode = 0660
listen.allowed_clients =

good luck!