Debian-repo not working with Debian sid


#1

I am trying to install the client on Debian Sid and I am running into this issue

rican-linux@debian-gazelle:~$ sudo apt install nextcloud-client nextcloud-client-nautilus
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nextcloud-client : Depends: libnextcloudsync0 (= 2.2.4-1.4) but it is not going to be installed
                    Depends: libssl1.0.0 (>= 1.0.0) but it is not installable
 nextcloud-client-nautilus : Depends: libnextcloudsync0 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

It looks like the issue is with libssl I am on 1.1 instad of 1.0

rican-linux@debian-gazelle:~$ openssl version
OpenSSL 1.1.0e  16 Feb 2017

Linux distribution packages for the desktop clients - help out!
#2

Which repo are you using? From @ivaradi? They only have a version for Debian 7 and Debian 8…