Debian 10 - clean - errors running NCP curl installer

Hi,

I am running NCP with a HC2 for more than a year over and I am happy with it.

I am now testing for instalation alternatives and I am i tried to run the NCP curl installer in a clean Debian 10 VPS from Contabo.com but the instalation stops/fails when installing or starting dnsmasq.

I start the service manually and run again the curl installer but when it is finished, and I open https://ip/
I am faced with the web error: “# Forbidden. You don’t have permission to access this resource.”

Trying https://ip:4443 does not open also

Logs are here: https://pastebin.com/Bd7JpcPs

Am I doing something wrong?

Thanks if advance for taking the time to help.

ER.

Sorry. Why are you installing NextcloudPi and not the normal Nextcloud.

Read perhaps this installation guide. It is very easy.

https://www.howtoforge.com/tutorial/how-to-install-nextcloud-on-debian-10

I think the only problem is the fact that it installs a pure Nextcloud 19 without old data. If you must restore old data (files and database) it is perhaps not so easy. Also with this installation you have no NextcloudPi-tools for backup, restore, …

1 Like

You could also try the official VM scripts:

1 Like

Hi,

Thank for taking the time to reply.

I am using NCP version because its webUI makes really easy to setup from, backups, other apps like Fail2Fan, LetsEnc, etc… also makes my life easier to migrate the data.

As you can imagine by my post, I am not a expert in nix systems but I manage to get around, I will give it a try as soon as I have the time.

NOTE: before running the NCP curl installer script, I installed manually dnsmasq and I no longer have the instalation stopped… however, I still get “Forbidden” on 443. I was really hoping this would a easy-peasy for the experts here :slight_smile:

Thanks again!

Hi,

Thank you also for the alternative option.

Indeed this is also one of the alternative options I was stuyding for the past days, a little more difficult to manage (for me) for not having the NCP webUI Panel :slight_smile:

ER.

1 Like

To access ncp-web at https://yourVpsIP:4443 and activation page.
You need to edit /etc/apache2/sites-available/ncp.conf
and /etc/apache2/sites-available/ncp-activation.conf (reload apache2.service)
and add a line (to the <RequireAny> section, to allow you to access from your IP
It is normally restricted to LAN and looks like this:

<RequireAny>
Require host localhost
Require local
Require ip 192.168
Require ip 172
Require ip 10
Require ip fd00::/8
Require ip fe80::/10
</RequireAny>

Insert a line with

Require ip YourIP

Alternatively, You can run ncp-config from the terminal to access the same apps you will find in ncp-web:4443
The ncp-config terminal interface is based on and similar to the raspi-config menu in raspbian. Not as fancy looking as web, but same tools.

1 Like

Hi Oliver,

Great input and thanks for helping.

Indeed the configuration was restricted to LAN IP pools unfortunately I added the IP address of the VPS but I still get “Forbidden”.

<VirtualHost _default_:443>
  DocumentRoot /var/www/ncp-web/
  SSLEngine on
  SSLCertificateFile      /etc/ssl/certs/ssl-cert-snakeoil.pem
  SSLCertificateKeyFile /etc/ssl/private/ssl-cert-snakeoil.key

</VirtualHost>
<Directory /var/www/ncp-web/>
  <RequireAll>

   <RequireAny>
      Require host localhost
      Require local
      Require ip 192.168
      Require ip 172
      Require ip 10
      Require ip fe80::/10
      Require ip fd00::/8
      Require ip 213.136.xxx.xxx
   </RequireAny>

  </RequireAll>
</Directory>

I restared Apache services and even went ahead and rebooted the VPS (it is quick as it is clean/empty). … but no go :frowning:

Do you have any other ideas?

Thank you,
ER

Not the ip of your VPS, your personal/private/home/office IP, from which you are connenting…
visit


to find out what is yours
1 Like

:exploding_head: obviously… I am such a idiot :rofl:

Thanks again for the patience, I will give it a try…

ER.

Worked like a charm :slight_smile:

@nachoparker in my case, the install script always fails right after installing dnsmasq and getting the service up… do you think it is worth it to investigate why I had to first install dnsmasq manually before running the curl installer?

thanks again @OliverV for the solution :wink:

ER.