DAVx5: http 404 not found (from android)

I have NC 17 running and can access files from android.
the file .Contacts… is uploaded.

but I get repeated error messages that from DAVx5 saying
HTTP server error - HTTP 404 not found.
(the contacts page in the web interface is empty. )

how can i get rid of the error message?


There seems something wrong with the contacts app then.
Please the nextcloud.log from the server then and details about your setup, like web server used, NC version and so on.

nextcloud.log is fine.
I checked the error message from dav on the droid:
it says:

<d:error xmlns:d=“DAV:” xmlns:s=“http://sabredav.org/ns”>
<s:message>Node with name ‘personal’ could not be found</s:message>

so it has nothing to do with contacts, but with the calendar.I disabled the calendar sync and will see whether the error comes again.

Are you sure that you’re using the correct url to access the calendar? It can easily been grepped by selecting the …-menue and selecting “Link”?!


The Calendar app is providing two types of URLs; one for general applications (like DAVx5) and one for iOS/ macOS. I suggest trying the first one for general caldav applications.


iOS/ macOS:

the first (General) one was used in the dav app.
I switched off the sync via dav, so I don’t get the error messages an longer.

I just checked the url I’m using with DAVx5 and it looks like this:


Therefore I would

  1. check why you are using // in the url.
  2. what exactly the user name is.
  3. what exactly the calendar name is and why it isn’t displayed in the url.

in DAV I set all syncing to only manual, AND unchecked the checkboxes for syncing calendar and contacts. But I still get 404 error messages that an Addressbook with the name contacts can not be found.

why are my setting ignored, and why is the server still connected for that purpose?

I think the Nextcloud help forum is the wrong place to ask DAVx5 support questions. You should search the DAVx5 support forum for an explanation or ask the developers if you couldn’t find an answer.