Dauerfehler: "trusted_domains" bearbeiten

Hallo alle zusammen,

ich hatte Proxmox neu installiert. Dafür hatte ich zuvor die VM’s auf eine externe Festplatte gebackupt und danach wieder eingespielt. Als solches gehen die VM’s wieder. Wir haben 4 Nextclouds laufen. Eine davon spinnt allerdings seit der Proxmox-Neuinstallation.
Netzwerkaufbau:
IONOS → OPNsense (Router) → reverse-proxy → Samba domain controller → nc4.domain.de
Gecheckt:

  • IP Adresse wird bei IONOS aktuell gehalten für nc4.domain.de
  • 80/443 Anfragen an meinen Internetanschluss werden zum Reverse Proxy weitergeleitet
  • Reverse Proxy leitet zu korrekt weiter
  • DNS-Auflösung funktioniert vorwärts und rückwärts
  • Aktuelle Zertifikate sind auf der Nextcloud-VM
  • config/config.php → trusted-domains
    Hier habe ich drei Schreibweisen ausprobiert die alle das gleiche Ergebnis bringen
  1. direkt
    ‘trusted_domains’ => ‘nc4.domain.de’,
  2. array alleine
    ‘trusted_domains’ =>
    array (
    1 => ‘nc4.domain.de’,
    )
  3. array wie gehabt und andere Nextcloud-VM’s
    ‘trusted_domains’ =>
    array (
    1 => ‘192.168.0.11’,
    2 => ‘nc4’,
    3 => ‘nc4.domain.de’,
    )

Ich bin nun mit meinem Wissen und Fantasie am Ende. Immer wenn ich über das Internet auf die Nextcloud zugreifen möchte, wird zwar eine Nextcloud Webseite geladen, aber es erscheint nur eine Fehlermeldung das ich bei den trusted_domains einen Fehler gemacht haben soll.
Hat einer von euch das selbe Problem bzw. hat einer von euch eine Idee woran es noch liegen könnte?

Vielen Dank im voraus
Freigeist

Ich kann es mir nicht richtig erklären, weil ich diesen Schritt gestern auch schon mal probierte, aber jetzt hatte es geholfen:

  • Auf der console als www-data anmelden
  • php occ maintenance:repair
1 Like

Ich habe mich gestern wohl geirrt, und habe nun doch keine Lösung. Ich sitze gerade in einer öffentlichen Bibliothek und wollte nun auf Daten in der Nextcloud zugreifen und bin wieder mit dem Fehler konfrontiert. Bitte um Hilfe/Unterstützung/Ideen.
Bildschirmfoto vom 2022-06-03 17-24-45

Ich habe ein Screenshot des Fehlers gemacht. Weiter unten ist ein Link zu Nextcloud. An der Stelle sollte aber ein Link mit entsprechender Bezeichnung zu dieser Nextcloud-Instanz sein. Nicht zum Hersteller Nextcloud.