Database missing oc_calendar_appt_configs

Hi everyone and thanks for taking the time to read me.

I have an issue of my calendar app not working and sending an “Internal error” page. After looking at the logs, it appears my database is missing the table “oc_calendar_appt_configs”. This comes from the last update that was leading to the error explained here : occ upgrade: The table with name 'db.oc_calendar_appt_configs' already exists · Issue #3857 · nextcloud/calendar · GitHub
On my side, to solve this issue I had simply removed the additional “oc_calendar_appt_configs” table from my database and the update of nextcloud had worked. I thought everything was fine and back to work but that’s because I wasn’t using the calendar yet. And now that I want to start using it, I discovered that I apparently removed all “oc_calendar_appt_configs” tables without noticing… So clever of me…

I checked all my daily database backups but it seems this table wasn’t there before that update so all happened on the day I handled the update of nextcloud and I cannot get it back from my backups. I also tried an “occ maintenance:repair” but that didn’t solve my problem either.

So to recap I am looking for a copy of the “oc_calendar_appt_configs” database table. Could anyone help me out on that ? Google’s results are deperatly empty on that matter :frowning:

Again many thanks for taking the time to read me and for any help you can provide !

Best regards,


Well, I managed to get back my missing table by installing a new nextcloud container from scratch aside of my existing installation. I had to install the calendar app within my nextcloud instance to get it back in my database, while uninstalling and re-installing the app in my current instance had not worked.
Hope this can help someone, closing the subject here.