"DATA on invalid stream"... Huh?

Hi there,

Please can someone help with this?

Nextcloud version 2.5.2git
Operating system and version Win10 Pro 10.0.17763

The issue you are facing: Messages for some files saying “DATA is on invalid stream”. What does this mean?

Is this the first time you’ve seen this error? No.

Steps to replicate it:

Simply synching between different devices (Android & Win)

Thank you!


I´ve exactly the same problem. Upload / sync from my desktop pc is no problem, but when I try to sync on my windows 10 laptop (download) I get “DATA is on invalid stream” for some files, but not for all. Size seems not to be a problem, as bigger files then the erroneous files were synchronized successfully.
Both machines run nextcloud client 2.5.2., server is on 16.0.3. Server-side encryption is enabled.


The same problem / error message here.

Running Nextcloud 2.5.1 on Opensuse Leap 15.1

Hallo zusammen,

bei mir die selbe Meldung. Was ist das?

I’m experiencing the same issue on 16.04. Any ideas?

Same on NC16

Have the same issue on Windows 10, but it disappeared on the second try! It was specific files only (some PDFs and some eBooks). I’m using server version and client v2.6 stable.

I did not encounter the issue yet on another OS.

I’m having this problem too. How to solve it?

I had that, too. v17.0.2. In my case, the data volume was full (although the majority was already in the nextcloud trashbin). That’s the file system on the server, not the quota, mind you. It seems, nextcloud isn’t very good at purging files from the trashbin when space is needed (I believe it’s supposed to do that automatically?). Also, cleaning up the trashbin manually via web frontend threw an unspecified error. I’m in the process of trying to fix that by restarting, cleaning up, removing files, retrying… I’lll report when or if I have more insight.

Edit: I could delete files from the trashbin individually and thus reclaim space. Trying to delete multiple files from the trashbin almost always resulted in an error. The same error occurred when I deleted files more quickly, so there might be an issue with parallelization of deletions.

Edit II: probably sudo -u www-data php occ trashbin:cleanup --all-users could have helped, too.
According to some - possibly dated - info, the “Deleted Files” - app should clean up files when needed, and also start to delete files after 50% of the available space are claimed by trash. In my case, more than 70% of the available space were claimed by files in the trashbin. Also, files were three months old and not deleted although I didn’t change the default, which is supposed to be at 30 days. Apparently, the whole “Deleted Files” - handling is borked. But that’s another issue.

Edit III: In case it isn’t clear, after cleanup sync worked and above error message disappeared.