Data dir not found - MariaDB not running - docker


I’ve done some bad things again and for some reason nextcloudpi doesn’t want to work. I can get into ncp-config, but I cannot get into any of the web Gui’s.

When I attempt nc-backup I get the message
Error reading data directory. Is NextCloud running and configured?
Similarly when I run nc-fix-permissions I get:
data dir not found

I’m thinking this is a problem, but I have no idea how to solve it as my data is there.

I’m running nextcloudpi ver. 0.57.17 via docker on a raspberry pi. And I get this when I run nc-info (slightly edited to remove identifying information)

Gathering information...
NextCloudPi version  v0.57.17
NextCloudPi image    NextCloudPi_05-30-18
distribution         Debian GNU/Linux 9 \n \l
USB devices          sda sdb
datadir              /data/app/data
data in SD           no
data filesystem      ext2/ext3
data disk usage      21G/166G
rootfs usage         1.4G/16G
swapfile             /var/swap
dbdir                /data/database
Nextcloud check      error
HTTPD service        down
PHP service          up
MariaDB service      down
Redis service        up
Postfix service      up
internet check       ok
port check 80        closed
port check 443       closed
interface            eth0
NAT loopback         no
uptime               57min

Alright, I’m concerned about a few things here. For starters it shows the port checks are not working. I’m not sure what it does to check these ports, so this may be ok as I’m mapping 8080 to 80 in the container and 444 to 443 in the container. So if it’s doing some sort of ping out and back to itself… well it’s possible this is right and it doesn’t know it. But I’m thinking this is actually an issue.

Beyond that the HTTPD and MariaDB services are down and under “nextcloudcheck” it says error. How can I start these services?

Any idea what I might need to do to get this thing back and rolling?

1 Like

Any helpers?

If someone wants to mark this closed we can do that. I didn’t so much solve it as I was able to find a database backup from a while ago and restore that. Then given that the data was still ok I rsync’ed the users’ data to that instance and used nc-scan to pull it into nextcloud. I may be missing a few items from the database but this is functionally fixed.