Das "No cache entry found for" Problem

Hallo Community,

bei mir in den Admin-Logs taucht unter “Debug” dauernt der Eintrag

No cache entry found for /appdata_ocaf358h5aa4/css/icons/icons-vars.css.gzip (storage: local::/var/www/nextcloud_data/data/, internalPath: appdata_ocaf358h5aa4/css/icons/icons-vars.css.gzip)

oder

No cache entry found for /appdata_ocaf358h5aa4/preview/148619 (storage: local::/var/www/nextcloud_data/data/, internalPath: appdata_ocaf358h5aa4/preview/148619)

gerne auch

No cache entry found for /appdata_ocaf358h5aa4/preview/148618 (storage: local::/var/www/nextcloud_data/data/, internalPath: appdata_ocaf358h5aa4/preview/148618)

auf. Was hat es damit auf sich und wie kann ich das beheben? Unter “Sicherheits- & Einrichtungswarnungen” hat meine Cloud alles bestanden. Meine config sieht wie folgt aus:

‘datadirectory’ => ‘BEISPIEL’,
‘overwrite.cli.url’ => ‘BEISPIEL’,
‘dbtype’ => ‘mysql’,
‘version’ => ‘14.0.3.0’,
‘dbname’ => ‘nextcloud’,
‘dbhost’ => ‘localhost’,
‘dbport’ => ‘’,
‘dbtableprefix’ => ‘oc_’,
‘dbuser’ => ‘oc_DepotCEO’,
‘dbpassword’ => ‘BEISPIEL’,
‘installed’ => true,
‘maintenance’ => false,
‘theme’ => ‘’,
‘loglevel’ => 0,
‘mail_from_address’ => ‘BEISPIEL’,
‘mail_smtpmode’ => ‘smtp’,
‘mail_smtpauthtype’ => ‘LOGIN’,
‘mail_domain’ => ‘BEISPIEL’,
‘mail_smtpauth’ => 1,
‘mail_smtpsecure’ => ‘ssl’,
‘mail_smtphost’ => ‘BEISPIEL’,
‘mail_smtpport’ => ‘BEISPIEL’,
‘mail_smtpname’ => ‘BEISPIEL’,
‘mail_smtppassword’ => ‘BEISPIEL’,
‘memcache.local’ => ‘\OC\Memcache\APCu’,

Danke Danke,
Leon Watermann

Habe ich leider auch und warte auch noch auf eine Antwort.

Habe auch nichts im Internet gefunden was mir weiterhelfen konnte…

1 Like

@watermann1998
hast Du schon eine Lösung gefunden ??
Ich komme bei mir leider nicht weiter.
Gruss
Daniel

1 Like

Verwendest du die App “AppOrder”?

Unter Aktive Apps finde ich kein solches App.
Oder ist das irgendwo anders versteckt??

Ne, dann nutzt du sie nicht. Dachte es liegt vielleicht daran, das AppOrder auch Navigationssymbole verstecken kannn (verwende ich). Und da eine Fehlermeldung etwas von CSS enthält, dachte ich einen Zusammenhang entdeckt zu haben :smiley: Schade schade.

Bei mir kommt die Meldung immer sobald jemand was hochlädt.

No cache entry found for /admin/files/Photos/2018/10/18-10-22 11-14-48 0158.jpg (storage: home::admin, internalPath: files/Photos/2018/10/18-10-22 11-14-48 0158.jpg)

Oh, Stimmt! Ich auch!

Debug | no app in context | No cache entry found for /admin/files/file.file (storage: home::admin, internalPath: files/file.file)

Debug | no app in context | No cache entry found for /admin/files/gallery.cnf (storage: home::admin, internalPath: files/gallery.cnf)

Ahhhso! Schau mal bitte nach, wie die Rechteverteilung bei deinem NextCloud Datenornder ist. Bei mir hat der Besitzter, also www-data, Vollzugriff. Alle anderen dürfen aber nur schreiben und ausführen aber nicht lesen. Wer führt PHP den aus? www-data oder der root-Benutzer?

Also bei mir ist es http als Benutzer (Synology)
Habe die Rechte so gesetzt gemäss einer Anleitung im Netz.

1 Like

Welche Rechte hat denn dein Dateiordner?

Das muss ich dann mal zu Hause schauen. Habe jetzt mal die Nextcloud Mobile App gestartet und dann kommt sofort diese Meldung.

No cache entry found for /appdata_ocbbq8nfm8wz/theming/images/background (storage: local::/volume1/nextcloud-data_1/data/, internalPath: appdata_ocbbq8nfm8wz/theming/images/background)

1 Like

Sieht so aus…

Welches OS ist das?

Uiii Du fragst mich Sachen.
Auf der DS läuft Linux. Eigene Distribution von Syno.

1 Like

Ich habe mich mal bei meinem Kollegen informiert. Die Debug Info können wir gepflegt ignorieren. Wieso? Weil Debug-Meldungen für NextCloud AppEntwickler relevant sind. Die Debug-Meldungen sind auch interessant, wenn du vorher eine Warnung erhalten hast. Anhand der Debug-Info kannst du dann oft besser nachvollziehen, wieso es zu einem Fehler kam. In unserem Fall kommen die Meldungen alleine und ohne vorhergehende Warnung oder vorhergehendem Error, richtig? Das Problem ist, meiner Vermutung nach, dass kein Cache für die gerade erstellte Datei hinterlegt wurde. Wieso? Weil sie eben gerade erst erstellt wurde.

Lösung:
Da wir die Meldung nicht mehr brauchen kannst du das Loglevel einfach auf 1 setzen. Dadurch werden Debug-Meldungen nicht mehr aufgezeichnet. Falls du mal eine Warnung bekommst, mit der du nix angfangen kannst, setzt du das Loglevel einfach auf 0 zurück. Mache dies NICHT in der Adminoberfläche sondern in der “config.php” deiner NextCloud :slight_smile:.

Mehr zu den Logleveln gibs hier:

Gruß,
Leon Watermann

Hallo Leon,
merci für die Info.
Und Nein ich bekomme auch keine Error Meldung. Das mit den Log Einstellungen werde ich machen.
Merci…

1 Like

Kein Ding :slight_smile: