Custom CSS header image "can't load" using Theming

After some fantastic support by @deblan on a Custom Menu issue, I now have the following situation.

I want to have a custom header image, and I also want to have Custom Menu enabled and working. It appears it’s not possible to have both.

I run NC 19.0.4 via snap, on Ubuntu 20.04. Latest versions of Custom Menu and Theming.
I normally have Theming disabled, apparently this also makes Custom Menu not work. In this setup, I have edited the ‘example’ theme and I have a custom header image which works fine.

If I enable Theming, Custom Menu also starts working, but there seems to be no way to have a custom header image. I tried using Custom CSS, but the CSS I enter is not being picked up. I then found and edited the server.scss file, and replaced the background-image code there with my custom image. Firefox console complains that it “can’t load image”, and the image never shows.
If I leave the original server.scss intact, the random header image feature also doesn’t work - I can only change the colour of the header but it never shows any images.

If anyone can shed light on why this may be happening, I’d highly appreciate it.

Do you try !important!? Eg:

.yourSelector {
    theProperty: newValue !important;

Yep, tried !important, no luck.